aboutsummaryrefslogtreecommitdiffstats
path: root/community/hivex
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 08:06:53 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 08:12:51 +0000
commit92e6b35f7e964221d45c6192dfd2638f1ebb08a5 (patch)
tree6cf19cfc609199568b11535865e5b0b53453f17c /community/hivex
parent1b54ef361d3f88a6303bdc6f034c427d3fc340cd (diff)
downloadaports-92e6b35f7e964221d45c6192dfd2638f1ebb08a5.tar.bz2
aports-92e6b35f7e964221d45c6192dfd2638f1ebb08a5.tar.xz
community/hivex: moved from testing
Diffstat (limited to 'community/hivex')
-rw-r--r--community/hivex/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/hivex/APKBUILD b/community/hivex/APKBUILD
new file mode 100644
index 0000000000..f08af81e6d
--- /dev/null
+++ b/community/hivex/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=hivex
+pkgver=1.3.13
+pkgrel=0
+pkgdesc="System for extracting the contents of Windows Registry."
+url="http://libguestfs.org"
+arch="all"
+license="LGPL2.1"
+depends=""
+makedepends="python-dev libxml2-dev readline-dev perl"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://libguestfs.org/download/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --bindir=/usr/bin \
+ --libdir=/usr/lib \
+ --prefix=/usr \
+ --disable-rpath \
+ --disable-perl \
+ --disable-ruby \
+ --disable-ocaml \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="a4c9cb138c0cb839759c54b59e52793f hivex-1.3.13.tar.gz"
+sha256sums="315bc304725309dc3cc844d1d1524055530fd18a1673fe3b95ef7892d0305591 hivex-1.3.13.tar.gz"
+sha512sums="5a045e90cbfc63f2fe317d04ef4dbfcd533968e3c635e8fa709fc58beabf442d7c3a7d2144995896dc221c454924c959ab9ccfa51454599dec0f7b26f955c072 hivex-1.3.13.tar.gz"