aboutsummaryrefslogtreecommitdiffstats
path: root/community/httpie
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-12-19 19:24:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-12-19 19:35:04 +0000
commit2fb4d03aef8e3de200880cf48dd30c9375118aaa (patch)
treec98d97f34b38cd4b860b043e8f390af141c769d9 /community/httpie
parent6c465ce6f5ebdf791b1587bed219c9fcadf4ba63 (diff)
downloadaports-2fb4d03aef8e3de200880cf48dd30c9375118aaa.tar.bz2
aports-2fb4d03aef8e3de200880cf48dd30c9375118aaa.tar.xz
community/httpie: merge changes from testing/httpie
update license, homepage, add check and modernize
Diffstat (limited to 'community/httpie')
-rw-r--r--community/httpie/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/httpie/APKBUILD b/community/httpie/APKBUILD
index 6064326f98..9c89a13e07 100644
--- a/community/httpie/APKBUILD
+++ b/community/httpie/APKBUILD
@@ -1,25 +1,31 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Daniel Isaksen <d@duniel.no>
pkgname=httpie
pkgver=0.9.9
-pkgrel=0
+pkgrel=1
pkgdesc="A CLI, cURL-like tool"
-url="https://github.com/jkbr/httpie"
+url="https://httpie.org/"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="python3 py3-requests py3-pygments"
makedepends="python3-dev"
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="e9adb1ecf9a25b57c634f35199bf1f8fbe4136179c0ba0d6032a41ae786da9344f54436f91d89e624c154bdca325f94c637364a934fc2d5742b83056434f7e4c httpie-0.9.9.tar.gz"