aboutsummaryrefslogtreecommitdiffstats
path: root/community/httpie
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 01:55:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 04:31:47 -0300
commite7a6c6a4ada7df3acf1ad057357840f8763e0ad3 (patch)
tree7ed16ae777c01ef8562f64dd00de0ca0e9315a77 /community/httpie
parent18c19551f613971c76359250e77582757de343f8 (diff)
downloadaports-e7a6c6a4ada7df3acf1ad057357840f8763e0ad3.tar.bz2
aports-e7a6c6a4ada7df3acf1ad057357840f8763e0ad3.tar.xz
community/httpie: upgrade to 1.0.3
Diffstat (limited to 'community/httpie')
-rw-r--r--community/httpie/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/httpie/APKBUILD b/community/httpie/APKBUILD
index 8c34213fc4..fe41cb43be 100644
--- a/community/httpie/APKBUILD
+++ b/community/httpie/APKBUILD
@@ -2,30 +2,30 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
# Contributor: Daniel Isaksen <d@duniel.no>
pkgname=httpie
-pkgver=1.0.2
-pkgrel=1
+pkgver=1.0.3
+pkgrel=0
pkgdesc="A CLI, cURL-like tool"
url="https://httpie.org/"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-requests py3-pygments"
-makedepends="python3-dev"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/h/httpie/httpie-$pkgver.tar.gz"
+
+# secfixes:
+# 1.0.3-r0:
+# - CVE-2019-10751
check() {
- cd "$builddir"
python3 setup.py check
}
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="cc0f2b8928d68bdd0c4eba96f499365d294429e909d91538c48f5028a55ca4a7ba41abdb94ef851459799f437457639b43ba408bb6336702d6042e7e5d5a9cbf httpie-1.0.2.tar.gz"
+sha512sums="b51779e0ec8f24108ee3f4bf690dc9dfddafff42509d1aa3d13ac12d65a93e02aad9644dc10134ebdbebf949b250cb288650a4dad3d382143e9ad3b9b0ac8c16 httpie-1.0.3.tar.gz"