aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3wm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-15 12:45:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-15 15:04:59 -0300
commita38f38bec1237fa0e9f95af7ce1035ec3dd7be85 (patch)
tree0d765afbee8f675d21b1beb1edfbc5ae12cae8a3 /community/i3wm
parente625d5538eb0fd9bd1029083b1d3e36af501dcd0 (diff)
downloadaports-a38f38bec1237fa0e9f95af7ce1035ec3dd7be85.tar.bz2
aports-a38f38bec1237fa0e9f95af7ce1035ec3dd7be85.tar.xz
community/i3wm: rebuild with GLOB_TILDE support
Diffstat (limited to 'community/i3wm')
-rw-r--r--community/i3wm/APKBUILD6
-rw-r--r--community/i3wm/i3wm-musl-glob-tilde.patch71
2 files changed, 2 insertions, 75 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
index 937efd98d5..e6831c7e76 100644
--- a/community/i3wm/APKBUILD
+++ b/community/i3wm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=i3wm
pkgver=4.17.1
-pkgrel=0
+pkgrel=1
pkgdesc="Improved dynamic tiling window manager"
url="https://i3wm.org"
arch="all"
@@ -31,7 +31,6 @@ subpackages="
"
source="
https://i3wm.org/downloads/i3-$pkgver.tar.bz2
- i3wm-musl-glob-tilde.patch
"
builddir="$srcdir/i3-$pkgver"
options="!check" # missing perl bindings for libxcb
@@ -58,5 +57,4 @@ savetree() {
mv "$pkgdir"/usr/bin/i3-save-tree "$subpkgdir"/usr/bin/
}
-sha512sums="af397dc1768ea6530e4b2ce8ef21b20ecff8ab9eebf380df224456173eea4c3bacf28b55c8efcdc70f76f0d66543c163564a94cfd66028221ace481fa3c2913f i3-4.17.1.tar.bz2
-c6ae3f22d0303da5de7ca4c92734b043a76d7447559fe2ffc308a8d135076cf05ee53ef63eb28c1bd628a1edfb2d1a0ed2d090836cb5fc70f2b882ee1105dad3 i3wm-musl-glob-tilde.patch"
+sha512sums="af397dc1768ea6530e4b2ce8ef21b20ecff8ab9eebf380df224456173eea4c3bacf28b55c8efcdc70f76f0d66543c163564a94cfd66028221ace481fa3c2913f i3-4.17.1.tar.bz2"
diff --git a/community/i3wm/i3wm-musl-glob-tilde.patch b/community/i3wm/i3wm-musl-glob-tilde.patch
deleted file mode 100644
index d4f9113e6b..0000000000
--- a/community/i3wm/i3wm-musl-glob-tilde.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- a/i3bar/src/main.c
-+++ b/i3bar/src/main.c
-@@ -48,14 +48,20 @@ void debuglog(char *fmt, ...) {
- *
- */
- static char *expand_path(char *path) {
-- static glob_t globbuf;
-- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
-- ELOG("glob() failed\n");
-- exit(EXIT_FAILURE);
-+ char *home, *expanded;
-+
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
-- globfree(&globbuf);
-- return result;
-+
-+ return sstrdup(path);
- }
-
- void print_usage(char *elf_name) {
---- a/libi3/resolve_tilde.c
-+++ b/libi3/resolve_tilde.c
-@@ -19,28 +19,18 @@
- *
- */
- char *resolve_tilde(const char *path) {
-- static glob_t globbuf;
-- char *head, *tail, *result;
-+ char *home, *expanded;
-
-- tail = strchr(path, '/');
-- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
--
-- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
-- free(head);
-- /* no match, or many wildcard matches are bad */
-- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
-- result = sstrdup(path);
-- else if (res != 0) {
-- err(EXIT_FAILURE, "glob() failed");
-- } else {
-- head = globbuf.gl_pathv[0];
-- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strcpy(result, head);
-- if (tail) {
-- strcat(result, tail);
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
- }
- }
-- globfree(&globbuf);
-
-- return result;
-+ return sstrdup(path);
- }