aboutsummaryrefslogtreecommitdiffstats
path: root/community/icinga2/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-09-23 07:15:49 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-09-23 07:16:03 +0000
commit7edc805805720ed31c5feea0a613a098cce401b1 (patch)
treee7d32c74513004b92bc7867f46e88b2941505de8 /community/icinga2/APKBUILD
parentf1211b12d81b8bce722774486b531d6ef6f03acc (diff)
downloadaports-7edc805805720ed31c5feea0a613a098cce401b1.tar.bz2
aports-7edc805805720ed31c5feea0a613a098cce401b1.tar.xz
community/icinga2: disable s390x arch
Build with s390 fails with this error: /usr/lib/gcc/s390x-alpine-linux-musl/9.2.0/../../../../s390x-alpine-linux-musl/bin/ld: /usr/lib/libboost_coroutine.so.1.71.0: undefined reference to `jump_fcontext' /usr/lib/gcc/s390x-alpine-linux-musl/9.2.0/../../../../s390x-alpine-linux-musl/bin/ld: /usr/lib/libboost_coroutine.so.1.71.0: undefined reference to `make_fcontext' collect2: error: ld returned 1 exit status make[2]: *** [plugins/CMakeFiles/check_nscp_api.dir/build.make:354: Bin/None/check_nscp_api] Error 1 make[1]: *** [CMakeFiles/Makefile2:2229: plugins/CMakeFiles/check_nscp_api.dir/all] Error 2 make[1]: *** Waiting for unfinished jobs....
Diffstat (limited to 'community/icinga2/APKBUILD')
-rw-r--r--community/icinga2/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index 157837cb73..9e4bb2d56d 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icinga2
pkgver=2.11.0
-pkgrel=0
+pkgrel=1
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
-arch="all !armhf !armv7"
+arch="all !armhf !armv7 !s390x"
license="GPL"
depends="monitoring-plugins"
makedepends="$depends_dev cmake bison flex boost-dev yajl-dev
@@ -20,17 +20,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pk
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- cd "$builddir"
- mkdir -p build
- default_prepare
-}
-
-check() {
- cd "$builddir"
- make test
-}
-
build() {
cd "$builddir"/build
cmake "$srcdir/$pkgname-$pkgver" \
@@ -52,6 +41,10 @@ build() {
make
}
+check() {
+ make test
+}
+
package() {
cd "$builddir"/build
make DESTDIR="$pkgdir" install