aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2-module-incubator
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-11-28 18:03:37 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-11-28 18:03:37 +0000
commit4287e522617311981cc5097547455862adf483ff (patch)
treea42d6998c46d02cc1cbc072925e6974190c9f5d0 /community/icingaweb2-module-incubator
parent8a76cdc32f5d2bb9ea6a24cbd4e3d87c22bae202 (diff)
downloadaports-4287e522617311981cc5097547455862adf483ff.tar.bz2
aports-4287e522617311981cc5097547455862adf483ff.tar.xz
community/icingaweb2-module-incubator: new aport, dependency of icingaweb2-module-director
Diffstat (limited to 'community/icingaweb2-module-incubator')
-rw-r--r--community/icingaweb2-module-incubator/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/icingaweb2-module-incubator/APKBUILD b/community/icingaweb2-module-incubator/APKBUILD
new file mode 100644
index 0000000000..daf8758db5
--- /dev/null
+++ b/community/icingaweb2-module-incubator/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="icingaweb2-module-incubator"
+_module=${pkgname/*-/}
+pkgver="0.5.0"
+pkgrel=0
+pkgdesc="Bleeding edge libraries useful for Icinga Web 2 modules"
+url="https://www.icinga.org"
+arch="noarch !armhf !armv7"
+license="GPL"
+options="!check"
+_php=php7
+depends="icingaweb2 icingaweb2-module-ipl icingaweb2-module-reactbundle"
+pkggroups="icingaweb2"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ return 0
+}
+
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/etc/icingaweb2/modules/$_module"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ cp -a vendor bin composer.json composer.lock module.info run.php \
+ "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ chgrp -R $pkggroups "$pkgdir/etc/icingaweb2/modules/$_module"
+
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
+
+For nginx, as example:
+ # chown -R nginx /etc/icingaweb2/modules/$_module
+or
+ # chown -R nobody /etc/icingaweb2/modules/$_module
+
+For Apache:
+ # chown -R apache /etc/icingaweb2/modules/$_module
+
+For lighttpd:
+ # chown -R lighttpd /etc/icingaweb2/modules/$_module
+
+Remember to enable the module with:
+
+ # icingacli $_module module enable $_module
+
+EOF
+
+}
+
+
+sha512sums="9a0c8591bc81da3b620272d86cd5fbd4640e3a8258facdd15875f58fa8cc14290c11ba6e880d630bb6a520083e15f578eacd352c942cbf1d9f656ff4ba5d97d7 icingaweb2-module-incubator-0.5.0.tar.gz"