aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2-module-ipl/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-11-28 18:02:14 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-11-28 18:02:14 +0000
commit8a76cdc32f5d2bb9ea6a24cbd4e3d87c22bae202 (patch)
tree1766701e5abf02689994869f831da4a26109b3a7 /community/icingaweb2-module-ipl/APKBUILD
parente0cde28a1a286cef14e6a7acadc5476b4a166900 (diff)
downloadaports-8a76cdc32f5d2bb9ea6a24cbd4e3d87c22bae202.tar.bz2
aports-8a76cdc32f5d2bb9ea6a24cbd4e3d87c22bae202.tar.xz
community/icingaweb2-module-ipl: new aport, dependency of icingaweb2-module-director
Diffstat (limited to 'community/icingaweb2-module-ipl/APKBUILD')
-rw-r--r--community/icingaweb2-module-ipl/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/icingaweb2-module-ipl/APKBUILD b/community/icingaweb2-module-ipl/APKBUILD
new file mode 100644
index 0000000000..9f9bc1f19d
--- /dev/null
+++ b/community/icingaweb2-module-ipl/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="icingaweb2-module-ipl"
+_module=${pkgname/*-/}
+pkgver="0.4.0"
+pkgrel=0
+pkgdesc="The Icinga PHP library for Icinga Web 2"
+url="https://www.icinga.org"
+arch="noarch !armhf !armv7"
+license="GPL"
+options="!check"
+_php=php7
+pkggroups="icingaweb2"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ return 0
+}
+
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/etc/icingaweb2/modules/$_module"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ cp -a vendor bin composer.json composer.lock module.info run.php \
+ "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ chgrp -R $pkggroups "$pkgdir/etc/icingaweb2/modules/$_module"
+
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
+
+For nginx, as example:
+ # chown -R nginx /etc/icingaweb2/modules/$_module
+or
+ # chown -R nobody /etc/icingaweb2/modules/$_module
+
+For Apache:
+ # chown -R apache /etc/icingaweb2/modules/$_module
+
+For lighttpd:
+ # chown -R lighttpd /etc/icingaweb2/modules/$_module
+
+Remember to enable the module with:
+
+ # icingacli $_module module enable $_module
+
+EOF
+
+}
+
+
+sha512sums="45678b0d011d97f5224253da718becd5526ca0d0aea59813953fdb3fb70f521131f5e1e9b2a52d9e30bce96bc650c469cbeaa67e3eebe04e50b44ae0c996ff95 icingaweb2-module-ipl-0.4.0.tar.gz"