aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2-module-reactbundle
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-11-28 18:01:51 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-11-28 18:01:51 +0000
commite0cde28a1a286cef14e6a7acadc5476b4a166900 (patch)
tree44fa4ea270774601847ef40f4865b08e0c2d22b8 /community/icingaweb2-module-reactbundle
parentcb6c628ddf31285b62bdaf9ba974c4459a973e09 (diff)
downloadaports-e0cde28a1a286cef14e6a7acadc5476b4a166900.tar.bz2
aports-e0cde28a1a286cef14e6a7acadc5476b4a166900.tar.xz
community/icingaweb2-module-reactbundle: new aport, dependency of icingaweb2-module-director
Diffstat (limited to 'community/icingaweb2-module-reactbundle')
-rw-r--r--community/icingaweb2-module-reactbundle/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/community/icingaweb2-module-reactbundle/APKBUILD b/community/icingaweb2-module-reactbundle/APKBUILD
new file mode 100644
index 0000000000..54d3dd3f07
--- /dev/null
+++ b/community/icingaweb2-module-reactbundle/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="icingaweb2-module-reactbundle"
+_module=${pkgname/*-/}
+pkgver="0.7.0"
+pkgrel=0
+pkgdesc="ReactPHP-based 3rd party libraries for Icinga Web 2"
+url="https://www.icinga.org"
+arch="noarch !armhf !armv7"
+license="GPL"
+options="!check"
+_php=php7
+pkggroups="icingaweb2"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/etc/icingaweb2/modules/$_module"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ cp -a vendor bin composer.json composer.lock module.info run.php \
+ "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ chgrp -R $pkggroups "$pkgdir/etc/icingaweb2/modules/$_module"
+
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
+
+For nginx, as example:
+ # chown -R nginx /etc/icingaweb2/modules/$_module
+or
+ # chown -R nobody /etc/icingaweb2/modules/$_module
+
+For Apache:
+ # chown -R apache /etc/icingaweb2/modules/$_module
+
+For lighttpd:
+ # chown -R lighttpd /etc/icingaweb2/modules/$_module
+
+Remember to enable the module with:
+
+ # icingacli $_module module enable $_module
+
+EOF
+}
+
+sha512sums="e5991be8d75940368f63cc2dac2fdc7b629f8227105c6398a7ba0bfd9cef34bf0bd431a05546de9dcea2af48d0912a1171ad21b1c454ae751ea3b9f636b0c443 icingaweb2-module-reactbundle-0.7.0.tar.gz"