aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-04-22 18:10:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-04-22 18:10:18 +0000
commit2094d852cd04636a3ed2ed70a534cfe3ab8bfd43 (patch)
tree3b8a7cc5fe77139abebef4800581355f41baee9d /community/icingaweb2
parent96cdb8e9e6b70a355eea850624277ed687d4be12 (diff)
downloadaports-2094d852cd04636a3ed2ed70a534cfe3ab8bfd43.tar.bz2
aports-2094d852cd04636a3ed2ed70a534cfe3ab8bfd43.tar.xz
community/icingaweb2: moved from testing
Diffstat (limited to 'community/icingaweb2')
-rw-r--r--community/icingaweb2/APKBUILD77
1 files changed, 77 insertions, 0 deletions
diff --git a/community/icingaweb2/APKBUILD b/community/icingaweb2/APKBUILD
new file mode 100644
index 0000000000..b5209494eb
--- /dev/null
+++ b/community/icingaweb2/APKBUILD
@@ -0,0 +1,77 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=icingaweb2
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Web Interface for Icinga2"
+url="http://www.icinga.org"
+arch="noarch"
+license="GPL"
+depends="icinga2 php php-gd php-ldap php-intl php-pgsql php-mysql
+ php-gettext php-ctype icinga2 php-openssl php-json php-dom
+ php-imagick php-pdo_mysql php-pdo_pgsql"
+depends_dev=""
+makedepends="$depends_dev"
+pkggroups="www-data"
+install=""
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/${pkgname}/archive/v${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir/etc/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/webapps/$pkgname"
+ mkdir -p "$pkgdir/var/log/$pkgname"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ cp -r application doc library modules public bin etc "$pkgdir"/usr/share/webapps/$pkgname
+ ln -s /usr/share/webapps/icingaweb2/bin/icingacli "$pkgdir"/usr/bin/icingacli
+ chmod 2770 "$pkgdir"/etc/$pkgname
+ chmod 750 "$pkgdir"/var/log/$pkgname
+ chgrp -R $pkggroups "$pkgdir"/etc/$pkgname
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/icingaweb2/LICENSE"
+
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to change the owner of log dir according with the user of your webserver:
+
+For nginx, as example:
+ # chown -R nginx /var/log/icingaweb2
+
+For Apache:
+ # chown -R apache /var/log/icingaweb2
+
+For lighttpd:
+ # chown -R lighttpd /var/log/icingaweb2
+
+Also, you may remove the user of your webserver from group 'icingacmd' if no other icinga web interface is installed.
+EOF
+}
+
+bashcomp() {
+ depends="bash"
+ pkgdesc="Bash completions for $pkgname"
+ arch="noarch"
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ mv etc/bash_completion.d/icingacli "$subpkgdir"/usr/share/bash-completion/completions/icingacli
+}
+
+md5sums="47bf447eb653dce4a104fb564cc8ae2e icingaweb2-2.3.1.tar.gz"
+sha256sums="8fcf177275e84ccd803b8e13a1db43f859a49f3f830f1f234767517f1f69c03f icingaweb2-2.3.1.tar.gz"
+sha512sums="5e9e094d9e88e26bd52b84261b15cdfc8952dc32b99b3c2935eda12cc700589fc4b0b963e88d2456f62c3be24dc6c0b14eb0f5a57a31a0738068fac1f236235b icingaweb2-2.3.1.tar.gz"