aboutsummaryrefslogtreecommitdiffstats
path: root/community/imapsync
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-06-13 18:59:53 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-06-13 19:07:40 +0200
commit8d4dc5082f6b8b60b592d1d511a3d9b4a77481d1 (patch)
treee775408e04d03fc0978aa8b8b3236a4ef22bf696 /community/imapsync
parent429242b3c8d5605feddd24d07089fd5f468d353b (diff)
downloadaports-8d4dc5082f6b8b60b592d1d511a3d9b4a77481d1.tar.bz2
aports-8d4dc5082f6b8b60b592d1d511a3d9b4a77481d1.tar.xz
community/imapsync: add trivial check
Diffstat (limited to 'community/imapsync')
-rw-r--r--community/imapsync/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/imapsync/APKBUILD b/community/imapsync/APKBUILD
index 8f3a0918a4..bc421dc539 100644
--- a/community/imapsync/APKBUILD
+++ b/community/imapsync/APKBUILD
@@ -45,11 +45,16 @@ depends="perl-app-cpanminus
procps
"
makedepends="perl-module-scandeps perl-par-packer"
-options="!check" # tests.sh requires authors remote imap password
subpackages="$pkgname-doc"
source="https://github.com/$pkgname/$pkgname/archive/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+# NOTE: tests.sh requires authors remote imap password
+check() {
+ cd "$builddir"
+ ./imapsync --version
+}
+
package() {
cd "$builddir"