aboutsummaryrefslogtreecommitdiffstats
path: root/community/incron
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-01-13 15:43:54 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-13 15:43:54 +0100
commitbf1a5e076df6ac74bb741c10babfdbc4e5cb2b06 (patch)
tree36fcfa5aeee3222e909de184e3d79f4513c1300b /community/incron
parentb8b9587650875423230c5f9e60286c96858de4d5 (diff)
downloadaports-bf1a5e076df6ac74bb741c10babfdbc4e5cb2b06.tar.bz2
aports-bf1a5e076df6ac74bb741c10babfdbc4e5cb2b06.tar.xz
community/vnstat: upgrade to 1.16
Diffstat (limited to 'community/incron')
-rw-r--r--community/incron/APKBUILD56
-rw-r--r--community/incron/fix-headers.patch10
-rw-r--r--community/incron/incron-aarch64.patch13
-rw-r--r--community/incron/incrond.initd13
4 files changed, 92 insertions, 0 deletions
diff --git a/community/incron/APKBUILD b/community/incron/APKBUILD
new file mode 100644
index 0000000000..87abad27f8
--- /dev/null
+++ b/community/incron/APKBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=incron
+pkgver=0.5.10
+pkgrel=0
+pkgdesc="Inotify cron system"
+url="http://inotify.aiken.cz"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev argp-standalone"
+install=""
+subpackages="$pkgname-doc"
+options="suid"
+source="http://inotify.aiken.cz/download/incron/incron-$pkgver.tar.bz2
+ fix-headers.patch
+ incrond.initd
+ incron-aarch64.patch
+ "
+
+_builddir="$srcdir"/incron-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
+ install -Dm755 "$srcdir"/incrond.initd "$pkgdir"/etc/init.d/incrond \
+ || return 1
+ install -Dm644 incron.conf.example "$pkgdir"/etc/incron.conf || return 1
+}
+
+md5sums="038190dc64568883a206f3d58269b850 incron-0.5.10.tar.bz2
+2f732aef8ae8b49a0427e1d0d3c5281d fix-headers.patch
+07089c4a524ba7d89f75881693ba7647 incrond.initd
+02955914e0c8aed4ca3950b109c57a61 incron-aarch64.patch"
+sha256sums="852695df1d0c8a1ad182d41c8f8ce1417ac34e7fb6cd01e9c9c6d493c42e759f incron-0.5.10.tar.bz2
+aa69fa1ebfd48e6fba9921f136ac77b68f9b34e6f60b2296c35bdd5b60e5d7ec fix-headers.patch
+c7a3c53543db190d2ce63667878c9968f9af7b9eabecbfc1cad7d9b8d937c8e4 incrond.initd
+690911bf841f43b5cb05e11d14ee7c2ccf310b9cc4079c02afa32e784b1c3dea incron-aarch64.patch"
+sha512sums="5d9ae4d4e3929ba16ad06652f21ef319041e13f9b15000d08053a973bef706b5d0137b9235c29049aed1673a2f41379b2b677eeedefacaf68308ad54405e4bfd incron-0.5.10.tar.bz2
+ab25665b6b736b81bfa84b1092608e0f2c15484a2e920b1859827bd870d04a894760020be6ab27226ff8cb75bab1ef8dc34d006a4531fc658e32137374412c9c fix-headers.patch
+458d5a4e9ab062b3e9a7dddf46c25bae431ec6c93862304f444e94cfb41b28e9ae21d5e621e94ce9cf55b26878d8fe978c19eeaa473779772a24adf709fd4cd8 incrond.initd
+46af5174748bec8ddad84f43b00a4b10f3bed3af2884fa4106797e96e2ea1be399642c049760035635275354a4a66d1ce33c58e6856bda3e98054c8627277287 incron-aarch64.patch"
diff --git a/community/incron/fix-headers.patch b/community/incron/fix-headers.patch
new file mode 100644
index 0000000000..64771ffd12
--- /dev/null
+++ b/community/incron/fix-headers.patch
@@ -0,0 +1,10 @@
+--- ./icd-main.cpp.orig
++++ ./icd-main.cpp
+@@ -24,6 +24,7 @@
+ #include <dirent.h>
+ #include <syslog.h>
+ #include <errno.h>
++#include <unistd.h>
+ #include <sys/poll.h>
+ #include <sys/stat.h>
+ #include <cstdio>
diff --git a/community/incron/incron-aarch64.patch b/community/incron/incron-aarch64.patch
new file mode 100644
index 0000000000..fe872ae35c
--- /dev/null
+++ b/community/incron/incron-aarch64.patch
@@ -0,0 +1,13 @@
+Index: incron-0.5.10/inotify-cxx.h
+===================================================================
+--- incron-0.5.10.orig/inotify-cxx.h
++++ incron-0.5.10/inotify-cxx.h
+@@ -37,7 +37,7 @@
+ #include <sys/inotify.h>
+
+ // Use this if syscalls not defined
+-#ifndef __NR_inotify_init
++#if not defined(__NR_inotify_init) && not defined(__aarch64__)
+ #include <sys/inotify-syscalls.h>
+ #endif // __NR_inotify_init
+
diff --git a/community/incron/incrond.initd b/community/incron/incrond.initd
new file mode 100644
index 0000000000..6aa4c0688d
--- /dev/null
+++ b/community/incron/incrond.initd
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/files/incrond.init,v 1.1 2011/01/31 15:14:12 idl0r Exp $
+
+command=/usr/sbin/incrond
+pidfile=/var/run/incrond.pid
+command_args="-f /etc/incron.conf"
+
+depend() {
+ use clock logger
+ need localmount
+}