aboutsummaryrefslogtreecommitdiffstats
path: root/community/influxdb/APKBUILD
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2020-01-04 15:19:23 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-06 08:03:13 +0100
commitbde48dc03d248e0ba0dba29c7d244899d19ccc9f (patch)
treeb13b386a147391bd7c56779c3607a09cdff91356 /community/influxdb/APKBUILD
parent2324155061dc8ad7bb43a209b47d72332b7caf0e (diff)
downloadaports-bde48dc03d248e0ba0dba29c7d244899d19ccc9f.tar.bz2
aports-bde48dc03d248e0ba0dba29c7d244899d19ccc9f.tar.xz
community/influxdb: enable aarch64
Diffstat (limited to 'community/influxdb/APKBUILD')
-rw-r--r--community/influxdb/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/influxdb/APKBUILD b/community/influxdb/APKBUILD
index 76e5615213..98b1f55eee 100644
--- a/community/influxdb/APKBUILD
+++ b/community/influxdb/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.7.7
pkgrel=0
pkgdesc="Scalable datastore for metrics, events, and real-time analytics"
url="https://www.influxdata.com/time-series-platform/influxdb/"
-arch="all !aarch64 !x86"
+arch="all !x86"
license="MIT"
makedepends="go dep python2 asciidoc xmlto"
install="$pkgname.pre-install"
@@ -40,7 +40,8 @@ build() {
check() {
# Failures on these arches
case $CARCH in
- s390x|arm*|ppc64le) return 0
+ s390x|arm*|aarch64|ppc64le) return 0
+ # aarch64: float precision issue (relative diff < 1E15, safe to ignore)
esac
go test -short ./...
}