aboutsummaryrefslogtreecommitdiffstats
path: root/community/iotop/fix-python.patch
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-05 19:53:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-10 11:50:04 +0000
commit930dd957fc4c3895ad00712eb58c11fa6f743def (patch)
tree95d6741508f8a75aa133bd77733ef05de1be3062 /community/iotop/fix-python.patch
parent53799fafb0ac628eb98ec3092c74f8a11cf8d747 (diff)
downloadaports-930dd957fc4c3895ad00712eb58c11fa6f743def.tar.bz2
aports-930dd957fc4c3895ad00712eb58c11fa6f743def.tar.xz
community/iotop: upgrade to python3
Diffstat (limited to 'community/iotop/fix-python.patch')
-rw-r--r--community/iotop/fix-python.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/iotop/fix-python.patch b/community/iotop/fix-python.patch
new file mode 100644
index 0000000000..6f400f7df2
--- /dev/null
+++ b/community/iotop/fix-python.patch
@@ -0,0 +1,19 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1,15 +1,8 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+
+ from distutils.core import setup
+ from distutils.command import install as distutils_install
+ from iotop.version import VERSION
+-
+-# Dirty hack to make setup.py install the iotop script to sbin/ instead of bin/
+-# while still honoring the choice of installing into local/ or not.
+-if hasattr(distutils_install, 'INSTALL_SCHEMES'):
+- for d in distutils_install.INSTALL_SCHEMES.itervalues():
+- if d.get('scripts', '').endswith('/bin'):
+- d['scripts'] = d['scripts'][:-len('/bin')] + '/sbin'
+
+ setup(name='iotop',
+ version=VERSION,