aboutsummaryrefslogtreecommitdiffstats
path: root/community/iotop
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-05 19:53:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-10 11:50:04 +0000
commit930dd957fc4c3895ad00712eb58c11fa6f743def (patch)
tree95d6741508f8a75aa133bd77733ef05de1be3062 /community/iotop
parent53799fafb0ac628eb98ec3092c74f8a11cf8d747 (diff)
downloadaports-930dd957fc4c3895ad00712eb58c11fa6f743def.tar.bz2
aports-930dd957fc4c3895ad00712eb58c11fa6f743def.tar.xz
community/iotop: upgrade to python3
Diffstat (limited to 'community/iotop')
-rw-r--r--community/iotop/APKBUILD18
-rw-r--r--community/iotop/fix-python.patch19
2 files changed, 28 insertions, 9 deletions
diff --git a/community/iotop/APKBUILD b/community/iotop/APKBUILD
index 5acbc732a8..2c6b8feb68 100644
--- a/community/iotop/APKBUILD
+++ b/community/iotop/APKBUILD
@@ -2,30 +2,30 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=iotop
pkgver=0.6
-pkgrel=1
+pkgrel=2
pkgdesc="I/O monitoring tool"
url="http://guichaz.free.fr/iotop/"
arch="noarch"
license="GPL-2.0"
-depends="python2"
+depends="python3"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="python3-dev py3-setuptools"
install=""
subpackages="$pkgname-doc"
-source="http://guichaz.free.fr/iotop/files/iotop-$pkgver.tar.bz2"
+source="http://guichaz.free.fr/iotop/files/iotop-$pkgver.tar.bz2
+ fix-python.patch"
builddir="$srcdir"/iotop-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
-md5sums="5ef9456b26d7694abf3101a72e1e0d1d iotop-0.6.tar.bz2"
-sha256sums="3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8dcef75b iotop-0.6.tar.bz2"
-sha512sums="b1047da3bc46604447cc8ab22442a3a5381e1a79a6b176fe9ee8402ee5cebb959205407a6aeaffccccde9d2f67624ff8ee6717b051838f13ab88bf3a16db3ab9 iotop-0.6.tar.bz2"
+sha512sums="b1047da3bc46604447cc8ab22442a3a5381e1a79a6b176fe9ee8402ee5cebb959205407a6aeaffccccde9d2f67624ff8ee6717b051838f13ab88bf3a16db3ab9 iotop-0.6.tar.bz2
+df5b09b20dc5ca3a8e73f39089f8ef2dbc5060b35178067a41ab1fd075922a860458611d5b0e7beb7aca8c9c5853998aeb7529dbccff9ef39daf17cd997cd698 fix-python.patch"
diff --git a/community/iotop/fix-python.patch b/community/iotop/fix-python.patch
new file mode 100644
index 0000000000..6f400f7df2
--- /dev/null
+++ b/community/iotop/fix-python.patch
@@ -0,0 +1,19 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1,15 +1,8 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+
+ from distutils.core import setup
+ from distutils.command import install as distutils_install
+ from iotop.version import VERSION
+-
+-# Dirty hack to make setup.py install the iotop script to sbin/ instead of bin/
+-# while still honoring the choice of installing into local/ or not.
+-if hasattr(distutils_install, 'INSTALL_SCHEMES'):
+- for d in distutils_install.INSTALL_SCHEMES.itervalues():
+- if d.get('scripts', '').endswith('/bin'):
+- d['scripts'] = d['scripts'][:-len('/bin')] + '/sbin'
+
+ setup(name='iotop',
+ version=VERSION,