aboutsummaryrefslogtreecommitdiffstats
path: root/community/ipmiutil/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:40 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:40 +0000
commit2fdd33f3eb99b9e8503b37e5557d01f019c463de (patch)
tree2c179c3f2fda1e88d0cec0cc111407d61fe8561e /community/ipmiutil/APKBUILD
parent18021183ae719aceeb17a90a6676469b6f9435ce (diff)
downloadaports-2fdd33f3eb99b9e8503b37e5557d01f019c463de.tar.bz2
aports-2fdd33f3eb99b9e8503b37e5557d01f019c463de.tar.xz
community/ipmiutil: move from testing
Diffstat (limited to 'community/ipmiutil/APKBUILD')
-rw-r--r--community/ipmiutil/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/ipmiutil/APKBUILD b/community/ipmiutil/APKBUILD
new file mode 100644
index 0000000000..4bf635a85f
--- /dev/null
+++ b/community/ipmiutil/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: A. Wilcox <AWilcox@Wilcox-Tech.com>
+pkgname=ipmiutil
+pkgver=3.0.7
+pkgrel=0
+pkgdesc="IPMI Management Utilities"
+url="http://ipmiutil.sourceforge.net/"
+arch="all"
+options="!check" # No test suite shipped.
+license="BSD-2-clause BSD-3-clause GPL-2.0"
+depends=""
+depends_dev="openssl-dev"
+makedepends="$depends_dev linux-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/project/ipmiutil/ipmiutil-$pkgver.tar.gz
+ ipmiutil-3.0.7-fix-sha256.patch
+ "
+
+prepare() {
+ default_prepare
+ update_config_guess
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-systemd \
+ --enable-sha256 \
+ --enable-gpl
+ make -j1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="26a0c805f2c49102eee44052814a6f7af67c74082489e70b058bd4350526a65aad1e1352e33b12e1afeae5e9e96fd2eb361fc6a112d38782dee58f95c3e2a13b ipmiutil-3.0.7.tar.gz
+74e8951bccd004f765b99de87dc5f04834e594b3e14ba885148fb971eaf15164ccac2de880e409f201a38cba5c0948a0fabc04e1e34fb396f50b1ecddb6b305b ipmiutil-3.0.7-fix-sha256.patch"