aboutsummaryrefslogtreecommitdiffstats
path: root/community/ipython
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-03-17 21:59:38 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-04 06:04:24 +0000
commit47f423ab2506c081e0951a189c55afa613aca560 (patch)
tree53159dd8be0e92152d8116361f3af794118c0fed /community/ipython
parent38278dab8f210a525a4f158a3f93970311698cb3 (diff)
downloadaports-47f423ab2506c081e0951a189c55afa613aca560.tar.bz2
aports-47f423ab2506c081e0951a189c55afa613aca560.tar.xz
testing/ipython: move to community
Diffstat (limited to 'community/ipython')
-rw-r--r--community/ipython/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/ipython/APKBUILD b/community/ipython/APKBUILD
new file mode 100644
index 0000000000..f78bc2dbda
--- /dev/null
+++ b/community/ipython/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=ipython
+pkgver=7.3.0
+pkgrel=0
+pkgdesc="A rich toolkit to help you make the most of using Python interactively"
+url="https://ipython.org/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ py3-traitlets
+ py3-pexpect
+ py3-prompt_toolkit>2.0.0
+ py3-jedi
+ py3-pygments
+ py3-pickleshare
+ py3-decorator
+ py3-backcall
+ py3-simplegeneric
+ py3-setuptools
+ "
+checkdepends="py-pathlib2"
+makedepends="python3-dev py-setuptools"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver/"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="825a466763ad3c57f7e8dbc15f66735e5bd686c77f3b5f8d147baea51a703849ad8c070136e06b3472de3f402bb99300e6ad8d62c1f94c361a6838ba4ae9e42a ipython-7.3.0.tar.gz"