aboutsummaryrefslogtreecommitdiffstats
path: root/community/iwd
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-11-16 22:54:48 +0100
committerMilan P. Stanić <mps@arvanta.net>2019-11-16 22:57:14 +0100
commit95dfaee92f485567b2bebbef22963fd6dd51bb68 (patch)
tree08501f5102c5aa00dad7cc37f4dd97fc0854601a /community/iwd
parentdc4a3ccf9a42f3bdaf8ed9e3542749c7266aeae0 (diff)
downloadaports-95dfaee92f485567b2bebbef22963fd6dd51bb68.tar.bz2
aports-95dfaee92f485567b2bebbef22963fd6dd51bb68.tar.xz
community/iwd: upgrade to 1.1
add patch to fix rawmemchr which is missing in musl, afaik add local /etc/iwd/main.conf file because it is remove upstream
Diffstat (limited to 'community/iwd')
-rw-r--r--community/iwd/APKBUILD12
-rw-r--r--community/iwd/fix-rawmemchr.patch11
-rw-r--r--community/iwd/main.conf167
3 files changed, 187 insertions, 3 deletions
diff --git a/community/iwd/APKBUILD b/community/iwd/APKBUILD
index d4aab81cfb..bb95de7401 100644
--- a/community/iwd/APKBUILD
+++ b/community/iwd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=iwd
-pkgver=1.0
+pkgver=1.1
pkgrel=0
pkgdesc="Internet Wireless Daemon"
url="https://iwd.wiki.kernel.org/"
@@ -14,7 +14,9 @@ subpackages="$pkgname-doc $pkgname-openrc"
source="https://mirrors.edge.kernel.org/pub/linux/network/wireless/iwd-$pkgver.tar.gz
dbus-netdev-group.patch
disable-eapol-test.patch
+ fix-rawmemchr.patch
iwd.initd
+ main.conf
"
build() {
./configure \
@@ -41,9 +43,13 @@ package() {
install -m750 -d "$pkgdir"/var/lib/$pkgname
install -m755 -D "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/main.conf \
+ "$pkgdir"/etc/$pkgname/main.conf
}
-sha512sums="303b1daa36261133a99859e8e307e42ea042c3c614019bcd72bcb5aefded117ba388adf537b9734c10ce375e31c84b2efb149e6bfc1322f50a25292ad7e2c8f2 iwd-1.0.tar.gz
+sha512sums="8fa39b5846d48b3d72e2c329a3c03f5cf8390703d08b76c84050a3b9c1a5231279944f6b865cd71df452372b24f2486717df7c59b24c80dce358e5d8c38a2376 iwd-1.1.tar.gz
7d3bc26b558ebfd22335b946f09abd5326e885275979c617af7def1468ade23ba7605f3b13aaf91836035c130aaec04be0ff2708a898f3ae835e0eef4e78fa0e dbus-netdev-group.patch
b3dfb5a2de110a8d6218fc6ec7f8e7690bc2ad130037051867d105aff23031d2340f55ac99f060d97856cb5818df24eb7631dc82dcbc196aa44251b2e5edcf7b disable-eapol-test.patch
-1a913fa19a76a18d92b8f44cb5b4b99a64b4e2f7d2b4a486bf1ba2f939aea7dcca772fca91483011ada58aaa3addc29c76ececd708b2187e57f72aa040ac77e6 iwd.initd"
+2d8cc70a9475465755f8187c6afb93e5792842dccf55f977ce111e98477517feae1be81eefd50c53149c61d7944a728dc504938ad678a2c789703bcc6f1e7507 fix-rawmemchr.patch
+1a913fa19a76a18d92b8f44cb5b4b99a64b4e2f7d2b4a486bf1ba2f939aea7dcca772fca91483011ada58aaa3addc29c76ececd708b2187e57f72aa040ac77e6 iwd.initd
+cc875faa69d5a0a673f923b6373a0d25e15166eef11b91d2ed75e99099e2087ba3d7930243b53cb6c53fc25bfe5f536268da7d40c7b286170388e813ce73d949 main.conf"
diff --git a/community/iwd/fix-rawmemchr.patch b/community/iwd/fix-rawmemchr.patch
new file mode 100644
index 0000000000..5ea018bd34
--- /dev/null
+++ b/community/iwd/fix-rawmemchr.patch
@@ -0,0 +1,11 @@
+--- a/src/wiphy.c 2019-11-14 21:04:59.000000000 +0100
++++ b/src/wiphy.c 2019-11-16 21:51:47.458144885 +0100
+@@ -500,7 +500,7 @@
+
+ if (out_num)
+ *out_num =
+- (uint8_t *) rawmemchr(wiphy->supported_rates[band], 0) -
++ (uint8_t *) strchr(wiphy->supported_rates[band], 0) -
+ wiphy->supported_rates[band];
+
+ return wiphy->supported_rates[band];
diff --git a/community/iwd/main.conf b/community/iwd/main.conf
new file mode 100644
index 0000000000..f53990339d
--- /dev/null
+++ b/community/iwd/main.conf
@@ -0,0 +1,167 @@
+# Note: The lines starting with # are ignored. To enable any of the
+# configuration options below, remove # from the beginning of a respective line.
+
+# this file is not distributed upstream as of iwd 1.0 version
+# It is picked from last version in which is distributed
+# Please read iwd.config(5), iwd.network(5), iwctl(1), iwmon(1) before setting
+# these parameters below
+
+[EAP]
+mtu=1400
+
+[EAPoL]
+max_4way_handshake_time=5
+
+[General]
+
+#
+# Enable network configuration. Setting this option to 'True' enables iwd to
+# configure the network interfaces with the IP addresses. There are two types
+# IP addressing supported by iwd: static and dynamic. The static IP addresses
+# are configured through the network configuration files located in
+# '/var/lib/iwd/' directory. For more information on the static configuration
+# options refer to the wiki page (https://iwd.wiki.kernel.org/ipconfiguration).
+# If no static IP configuration has been provided for a network, iwd will
+# attempt to obtain the dynamic addresses from the network through the built-in
+# DHCP client.
+#
+# The network configuration feature is disabled by default.
+#
+# enable_network_config=False
+
+#
+# Indicate a DNS resolution method used by the system. This configuration option
+# must be used in conjunction with 'enable_network_config'. The currently
+# supported methods include: systemd-resolved and the resolv.conf based options
+# (such as openresolv, etc).
+# The following configuration 'dns_resolve_method' options are supported:
+# systemd
+# resolvconf
+#
+# If not specified, 'systemd' is used as default.
+#
+# dns_resolve_method=resolvconf
+#
+
+#
+# Enable/Disable sending EAPoL packets over NL80211. Enabled by default if
+# kernel support is available. Doing so sends all EAPoL traffic over directly
+# to the supplicant process (iwd) instead of putting these on the Ethernet
+# device. Since only the supplicant can usually make sense / decrypt these
+# packets, enabling this option can save some CPU cycles on your system and
+# avoids certain long-standing race conditions.
+#
+# Note, iwmon cannot currently spy on unicast packets sent over netlink, so
+# if you need to capture EAPoL packets (e.g. for debugging) then this option
+# should be set to False.
+control_port_over_nl80211=True
+#
+# Set the threshold RSSI for roaming (default -70)
+roam_rssi_threshold=-70
+#
+# Do not allow iwd to destroy / recreate wireless interfaces at startup,
+# including default interfaces. Enable this behavior if your wireless card
+# driver is buggy or does not allow such an operation, or if you do not want
+# iwd to manage netdevs for another reason. For most users with an upstream
+# driver it should be safe to omit/disable this setting.
+# use_default_interface=true
+
+#
+# Explicitly enforce/disable management frame protection
+#
+# 0 - Disable management frame protection
+# 1 - Set management frame protection capable (default)
+# 2 - Management frame protection required
+#
+# management_frame_protection=1
+
+#
+# Enable/disable ANQP queries. The way IWD does ANQP queries is dependent on
+# a recent kernel patch (available in Kernel 5.3). If your kernel does not have
+# this functionality this should be disabled (default). Some drivers also do a
+# terrible job of sending public action frames (freezing or crashes) which is
+# another reason why this has been turned off by default. All aside, if you want
+# to connect to Hotspot 2.0 networks ANQP is most likely going to be required
+# (you may be able to pre-provision to avoid ANQP).
+#
+# disable_anqp=true
+
+#
+# Control the behavior of MAC address randomization by setting the
+# mac_randomize option. iwd supports the following options:
+# "default" - Lets the kernel assign a mac address from the permanent mac
+# address store when the interface is created by iwd. Alternatively,
+# if the 'use_default_interface' is set to true, then the mac address is
+# not touched.
+# "once" - MAC address is randomized once when iwd starts. If
+# 'use_default_interface' is set to true, only the interface(s) managed
+# by iwd will be randomized.
+#
+# One can control which part of the address is randomized using
+# mac_randomize_bytes option. iwd supports the following options:
+# "nic" - Randomize only the NIC specific octets (last 3 octets). Note that
+# the randomization range is limited to 00:00:01 to 00:00:FE. The permanent
+# mac address of the card is used for the initial 3 octets.
+# "full" - Randomize the full 6 octets. The locally-administered bit will
+# be set.
+#
+# mac_randomize=default
+# mac_randomize_bytes=full
+
+[Scan]
+#
+# Disable periodic scan. Setting this option to 'true' will prevent iwd from
+# issuing the periodic scans for the available networks while disconnected.
+# The behavior of the user-initiated scans isn't affected.
+# The periodic scan is enabled by default.
+#
+# disable_periodic_scan=false
+#
+
+#
+# Disable roaming scan. Setting this option to 'true' will prevent iwd from
+# issuing the roaming scans for the available networks while connected.
+# The behavior of the user-initiated scans isn't affected.
+# The roaming scan is enabled by default.
+#
+# disable_roaming_scan=false
+#
+
+#
+# Disable MAC address randomization. Setting this option to 'true' will prevent
+# the capable network adapters from randomizing MAC addresses during the active
+# scans for networks, thus decreasing user privacy.
+# The MAC address randomization is enabled by default.
+#
+# disable_mac_address_randomization=false
+#
+
+[Blacklist]
+#
+# Configure BSS blacklist time/multipler/max. If a connection to a BSS fails for
+# whatever reason we can avoid connecting to this BSS in the future by
+# blacklisting it. These three options configure how long a BSS is blacklisted
+# for.
+#
+# bss_blacklist_time - The initial timeout for a blacklisted BSS in
+# seconds (default 60)
+# bss_blacklist_multiplier - What bss_blacklist_time is multiplied by after
+# future unsuccessful connection attempts in
+# seconds (default 30)
+# bss_blacklist_max_time - The maximum time a BSS can be blacklisted for in
+# seconds (default 86400)
+#
+# bss_blacklist_time=60
+# bss_blacklist_multiplier=30
+# bss_blacklist_max_time=86400
+
+[Rank]
+#
+# Manually specify a 5G ranking factor. 5G networks are already preferred but
+# only in terms of calculated data rate, which is RSSI dependent. This means it
+# is still possible for IWD to prefer a 2.4GHz AP in the right conditions.
+# This ranking provides a way to further weight the ranking towards 5G if
+# required. Also, a lower 5G factor could be used to weight 2.4GHz if that is
+# desired. The default is 1.0, which does not affect the calculated ranking.
+#
+# rank_5g_factor=1.0