aboutsummaryrefslogtreecommitdiffstats
path: root/community/jsonrpc-glib
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:47:20 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:47:20 +0200
commite9457d3216f02fcbfd50290c059d5be8b78e0d87 (patch)
treeca39d9019671b9eddf98a135997a5795f451985b /community/jsonrpc-glib
parent8f13d62ec4f5078bc75ad37cc9b8ac00bd614541 (diff)
downloadaports-e9457d3216f02fcbfd50290c059d5be8b78e0d87.tar.bz2
aports-e9457d3216f02fcbfd50290c059d5be8b78e0d87.tar.xz
community/jsonrpc-glib: move from testing
Diffstat (limited to 'community/jsonrpc-glib')
-rw-r--r--community/jsonrpc-glib/APKBUILD33
-rw-r--r--community/jsonrpc-glib/disable-flaky-test.patch19
2 files changed, 52 insertions, 0 deletions
diff --git a/community/jsonrpc-glib/APKBUILD b/community/jsonrpc-glib/APKBUILD
new file mode 100644
index 0000000000..30726dae4e
--- /dev/null
+++ b/community/jsonrpc-glib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=jsonrpc-glib
+pkgver=3.34.0
+pkgrel=0
+pkgdesc="Library to communicate using the JSON-RPC 2.0 specification"
+url="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="gtk+3.0-dev vala gobject-introspection-dev gtk-doc meson json-glib-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/jsonrpc-glib/${pkgver%.*}/jsonrpc-glib-$pkgver.tar.xz
+ disable-flaky-test.patch"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --buildtype=release \
+ -Denable_gtk_doc=true \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="58908dd11f7848b09e63f7a7ff2185d0742c049ddffb033e768f783bcbcda7e75a658bec923372212694431b25b0fb894e3ea37ce2d7c52c99e49fd230319c10 jsonrpc-glib-3.34.0.tar.xz
+ec2eea185a86c6ac16fc51c7d67faca7805c69e6127f1288d551ba7249f898672a5a4ef1f2d05531f65e5d5087d4d576b251f3330806809bdeab6abd6593dc34 disable-flaky-test.patch"
diff --git a/community/jsonrpc-glib/disable-flaky-test.patch b/community/jsonrpc-glib/disable-flaky-test.patch
new file mode 100644
index 0000000000..6659289e3b
--- /dev/null
+++ b/community/jsonrpc-glib/disable-flaky-test.patch
@@ -0,0 +1,19 @@
+See https://gitlab.gnome.org/GNOME/jsonrpc-glib/issues/2
+diff --git a/tests/meson.build b/tests/meson.build
+index 40b410b..3318c79 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -38,13 +38,6 @@ test_server = executable('test-server', 'test-server.c',
+ )
+ test('test-server', test_server, env: test_env)
+
+-test_stress = executable('test-stress', 'test-stress.c',
+- c_args: test_cflags,
+- link_args: test_link_args,
+- dependencies: test_deps,
+-)
+-test('test-stress', test_stress, env: test_env)
+-
+ test_gauntlet = executable('test-gauntlet', 'test-gauntlet.c',
+ c_args: test_cflags,
+ link_args: test_link_args,