aboutsummaryrefslogtreecommitdiffstats
path: root/community/kaccounts-integration
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-27 15:02:39 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 15:49:41 +0100
commit6feaeb8e47d5928528ac398cefa4cb3b21a462d3 (patch)
tree678dc31d3f9621a88e6c0039eb98ea357fa42508 /community/kaccounts-integration
parent6096977d845bde953815a962c6433ef63c20a8cd (diff)
downloadaports-6feaeb8e47d5928528ac398cefa4cb3b21a462d3.tar.bz2
aports-6feaeb8e47d5928528ac398cefa4cb3b21a462d3.tar.xz
community/kaccounts-integration: move from testing
Diffstat (limited to 'community/kaccounts-integration')
-rw-r--r--community/kaccounts-integration/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/kaccounts-integration/APKBUILD b/community/kaccounts-integration/APKBUILD
new file mode 100644
index 0000000000..66e359cdd6
--- /dev/null
+++ b/community/kaccounts-integration/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kaccounts-integration
+pkgver=19.12.0
+pkgrel=1
+arch="all"
+url="https://kde.org/applications/internet/"
+pkgdesc="Small system to administer web accounts for the sites and services across the KDE desktop"
+license="GPL-2.0-or-later AND LGPL-2.1-or-later"
+depends="accounts-qml-module"
+depends_dev="qt5-qtbase-dev kcmutils-dev ki18n-dev kcoreaddons-dev kdbusaddons-dev kdeclarative-dev libaccounts-qt-dev signond-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kaccounts-integration-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+options="!check" # No tests available
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="c40775509f9c336974bef0effade36adf36e19398a0445e5d155a8e4e3062219da191fab912640c610799dc7d6bc114f7daa423fea97304714332b9f00db94b9 kaccounts-integration-19.12.0.tar.xz"