aboutsummaryrefslogtreecommitdiffstats
path: root/community/kalarm
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-13 11:38:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-14 15:45:20 +0000
commit6486fa402831e9c260166d80a955a167dfe04888 (patch)
tree91524f8a27322757886d999840c2b926f5fb0af9 /community/kalarm
parent5428b844d0eea9ddd85f718ff0c9fa648a907e72 (diff)
downloadaports-6486fa402831e9c260166d80a955a167dfe04888.tar.bz2
aports-6486fa402831e9c260166d80a955a167dfe04888.tar.xz
community/kalarm: move from testing
Diffstat (limited to 'community/kalarm')
-rw-r--r--community/kalarm/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/kalarm/APKBUILD b/community/kalarm/APKBUILD
new file mode 100644
index 0000000000..ec458d6ff1
--- /dev/null
+++ b/community/kalarm/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kalarm
+pkgver=19.12.3
+pkgrel=1
+arch="all !ppc64le !s390x !armhf !mips !mips64" # Limited by kmailtransport -> libkgapi -> qt5-qtwebengine
+url="https://kontact.kde.org/"
+pkgdesc="Personal alarm scheduler"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+depends="kdepim-runtime"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev kauth-dev kcodecs-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kdbusaddons-dev kdoctools-dev kglobalaccel-dev kguiaddons-dev ki18n-dev kiconthemes-dev kjobwidgets-dev kcmutils-dev kdelibs4support-dev kio-dev knotifications-dev kservice-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kholidays-dev phonon-dev kimap-dev akonadi-dev akonadi-contacts-dev akonadi-mime-dev kalarmcal-dev kcalendarcore-dev kcalutils-dev kidentitymanagement-dev kdepim-apps-libs-dev libkdepim-dev mailcommon-dev kmailtransport-dev kmime-dev pimcommon-dev kpimtextedit-dev libxslt-dev qgpgme"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kalarm-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make -C build
+}
+
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C build install
+}
+
+sha512sums="b004d2bf8433589857e9ba25774ccbfe3e1ebe6f3f3e098cba9178db99cc5fa40e32406abde0092fe5c6db979831abe4d78aa10a20156490796ade5c634e3042 kalarm-19.12.3.tar.xz"