aboutsummaryrefslogtreecommitdiffstats
path: root/community/karchive
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/karchive
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
downloadaports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.bz2
aports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.xz
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/karchive')
-rw-r--r--community/karchive/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/karchive/APKBUILD b/community/karchive/APKBUILD
index 77cb4aa61a..25a1761259 100644
--- a/community/karchive/APKBUILD
+++ b/community/karchive/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=karchive
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Qt 5 addon providing access to numerous types of archives"
arch="all"
@@ -12,8 +12,15 @@ makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/karchive-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="d29a68ac93141c31e762b204e474ec5040087f4f67dd4a30aba236341a48561dca826e7f5230822dd59cbe46609daa71b76f1c5b78b0e4f26f91e7122445afeb karchive-5.62.0.tar.xz"
+sha512sums="595ccdf4f584fc4d044960e52e8cba943f7f9150341b8461b3217044538f88410f25ece9a18c9a4f9296156e20e8629eb284964d3c3cdffcba2969b36924063e karchive-5.63.0.tar.xz"