aboutsummaryrefslogtreecommitdiffstats
path: root/community/kauth
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/kauth
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
downloadaports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.bz2
aports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.xz
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/kauth')
-rw-r--r--community/kauth/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
index c29fc4a5ae..054ad0841c 100644
--- a/community/kauth/APKBUILD
+++ b/community/kauth/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kauth
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Abstraction to system policy and authentication features"
arch="all"
@@ -12,8 +12,15 @@ makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,11 +29,13 @@ build() {
}
check() {
+ cd "$builddir"/build
# KAuthHelperTest hangs
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(KAuthHelperTest)'
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="c7ddb3c8a0e48ce51285e9fa0327d735971f0873201d4b2d5c59bb3b22d93f2dc3cb30398c342abbe88b87fb2c5395afc45b44385d9e0bc8ea3a1f673f5569f5 kauth-5.62.0.tar.xz"
+sha512sums="f4ef0874368b6c1543a9ee4b41039fe0a291d40c0535f5d1c1c1258dc842ea389c266bcd720d7039d6bccac52c1f305602b488c7018b1f9c7084f5fec63bfe73 kauth-5.63.0.tar.xz"