aboutsummaryrefslogtreecommitdiffstats
path: root/community/kauth
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/kauth
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/kauth')
-rw-r--r--community/kauth/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
new file mode 100644
index 0000000000..a8c8478dff
--- /dev/null
+++ b/community/kauth/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kauth
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Abstraction to system policy and authentication features"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev kcoreaddons-dev polkit-qt-1-dev"
+makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ # KAuthHelperTest hangs
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(KAuthHelperTest)'
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="f35c904f22d04af26cca20fdc4c565203ef929e8efb7678aed8aa97d14d8be35e06a03e7db64a2bc4c17f9983072208fa4350c85790cca784bc4f1d81b2a7fd9 kauth-5.60.0.tar.xz"