aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalc
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 14:08:42 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-15 11:36:41 +0100
commita3698bd3bce5b7a2e76c6d439fae4af875ec3d2d (patch)
tree92642bd5660ad9118888865f8fa4c101ee82b281 /community/kcalc
parentf68fba11e3d2125efe2416cbd7d0f429ab92ec1d (diff)
downloadaports-a3698bd3bce5b7a2e76c6d439fae4af875ec3d2d.tar.bz2
aports-a3698bd3bce5b7a2e76c6d439fae4af875ec3d2d.tar.xz
{community,testing}/kde-applications: upgrade to 19.08.3
Diffstat (limited to 'community/kcalc')
-rw-r--r--community/kcalc/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/kcalc/APKBUILD b/community/kcalc/APKBUILD
index 5f241c0300..f2bf3de72f 100644
--- a/community/kcalc/APKBUILD
+++ b/community/kcalc/APKBUILD
@@ -1,18 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcalc
-pkgver=19.08.2
+pkgver=19.08.3
pkgrel=0
arch="all"
url="https://kde.org/applications/utilities/org.kde.kcalc"
pkgdesc="Scientific Calculator"
license="GPL-2.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev kcrash-dev kconfig-dev kconfigwidgets-dev kdoctools-dev kguiaddons-dev ki18n-dev kinit-dev knotifications-dev kxmlgui-dev gmp-dev mpfr-dev"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/kcalc-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -20,11 +27,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="966e1239c11f77c162d5698708e96e8172bc99bc195df0ceff9b5867b7fd9f452091cc4d39286b8bf2febf9a75ee119d3f5282090d6bf8b02783ff8d0ed75424 kcalc-19.08.2.tar.xz"
+sha512sums="e27eefd90f3b32db383305e1eecade41545dfe8f9dd9a6c5b4f48b2082a7323e5a7d812ee54b45cea28c76ba6e82104e1fd2d001060f1588b4b1d62241421e7f kcalc-19.08.3.tar.xz"