aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalendarcore
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-22 11:04:46 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-22 08:53:26 -0300
commitfc985e689189162eeffb51e6dd94925db59ed996 (patch)
treecc82622c4de08195db040538c52174d5c1acb144 /community/kcalendarcore
parent6edb0fc395d64d77217461bf75cbb417b77327dc (diff)
downloadaports-fc985e689189162eeffb51e6dd94925db59ed996.tar.bz2
aports-fc985e689189162eeffb51e6dd94925db59ed996.tar.xz
community/kcalendarcore: move and rename from testing
Diffstat (limited to 'community/kcalendarcore')
-rw-r--r--community/kcalendarcore/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/kcalendarcore/APKBUILD b/community/kcalendarcore/APKBUILD
new file mode 100644
index 0000000000..a410355e4e
--- /dev/null
+++ b/community/kcalendarcore/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kcalendarcore
+pkgver=5.63.0
+pkgrel=0
+pkgdesc="The KDE calendar access library"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.0-or-later"
+depends_dev="qt5-qtbase-dev libical-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcalendarcore-$pkgver.tar.xz"
+subpackages="$pkgname-dev"
+
+replaces="kcalcore"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ # testrecurtodo, testreadrecurrenceid and testicaltimezones are broken
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "test(recurtodo|readrecurrenceid|icaltimezones)"
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="11b2a4e7d37ee435778a19f2dbfb9f5084d951bc5dafd8acbb6e36ae919fa97594bdfba6c542a63694745ae14c289b7a4d67136b0cefd70fed4212a0118be9cd kcalendarcore-5.63.0.tar.xz"