aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcodecs
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/kcodecs
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
downloadaports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.bz2
aports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.xz
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/kcodecs')
-rw-r--r--community/kcodecs/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kcodecs/APKBUILD b/community/kcodecs/APKBUILD
index a585d7aedc..4ba0cda41b 100644
--- a/community/kcodecs/APKBUILD
+++ b/community/kcodecs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcodecs
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Provide a collection of methods to manipulate strings using various encodings"
arch="all"
@@ -11,8 +11,15 @@ makedepends="extra-cmake-modules qt5-qttools-dev gperf doxygen"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -21,10 +28,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="eaf5546667365300f783cf2427c214aa04ce5a134a4f6165a4a6cbd982ffe6f9486ec7d5f698d714626866c7b1ac9b54848efaf234d240dd4bfb27a469aab405 kcodecs-5.62.0.tar.xz"
+sha512sums="5eaf0a5dea72aca6d2d4c7cfc4b32d005a6690f6738ce6511c15f5e2d5a3397d7728b691db3e1634f3c9f9a7744d78749092fd528cfda68f483b13372939a6b5 kcodecs-5.63.0.tar.xz"