aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdecoration
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/kdecoration
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
downloadaports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.bz2
aports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.xz
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/kdecoration')
-rw-r--r--community/kdecoration/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/kdecoration/APKBUILD b/community/kdecoration/APKBUILD
index d9ba698518..539d5ddcdc 100644
--- a/community/kdecoration/APKBUILD
+++ b/community/kdecoration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdecoration
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="Plugin based library to create window decorations"
arch="all"
@@ -9,12 +9,19 @@ url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="qt5-qtbase-dev ki18n-dev"
makedepends="$depends_dev extra-cmake-modules"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/kdecoration-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
options="!check" # Fails due to requiring running X11
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -22,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="aaf7c24f7f6c77661902bc219ac1448cf2542645fb96fcc18f5751ed775a722c745f6d71c2d6b0285103a99b68446bb3ae59ff9bd8279dcb635dee6927fc000e kdecoration-5.16.5.tar.xz"
+sha512sums="70a90d6232b1519324c1c1d9db2a66b5352ccfaa146c9618fe3bdb6bcdf7bac4a7758ebf50dc3ba669e6cfe34ca59b211b019449c33b406a206d6c292c27d971 kdecoration-5.17.0.tar.xz"