aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdesignerplugin
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/kdesignerplugin
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
downloadaports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.bz2
aports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.xz
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/kdesignerplugin')
-rw-r--r--community/kdesignerplugin/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kdesignerplugin/APKBUILD b/community/kdesignerplugin/APKBUILD
index fd1a7b4305..48ebab971a 100644
--- a/community/kdesignerplugin/APKBUILD
+++ b/community/kdesignerplugin/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdesignerplugin
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Integration of Frameworks widgets in Qt Designer/Creator"
arch="all"
@@ -13,8 +13,15 @@ checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/portingAids/kdesignerplugin-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -22,11 +29,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="5b1406df4174a0cbed3dfdda5b86912bd8547e4ad49339172637515584b70cb068282a208d941025c013176370f80eb4dd859a5936b68cbc37c77602b883a431 kdesignerplugin-5.62.0.tar.xz"
+sha512sums="192521cc2f16127d911fa4973a165c8916dfe41aaa832f51037037eed5b5e8a76b1c6ccabac96275cd39bf8ca3e912773c2f96b2522da508fa746cdcb3c67444 kdesignerplugin-5.63.0.tar.xz"