aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdesignerplugin
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/kdesignerplugin
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/kdesignerplugin')
-rw-r--r--community/kdesignerplugin/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/kdesignerplugin/APKBUILD b/community/kdesignerplugin/APKBUILD
new file mode 100644
index 0000000000..d096f9decd
--- /dev/null
+++ b/community/kdesignerplugin/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdesignerplugin
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Integration of Frameworks widgets in Qt Designer/Creator"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only"
+depends_dev="kcoreaddons-dev kconfig-dev kcompletion-dev kconfigwidgets-dev kiconthemes-dev kio-dev kitemviews-dev kplotting-dev ktextwidgets-dev kwidgetsaddons-dev kxmlgui-dev sonnet-dev"
+makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev kdoctools-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="994463669a7996894acd2526f8931ec3081ab801dfc690f2895c9d24c0342ea3f667666e47c0da5ed5a9ae232c7425a7f23aa02792d00eecae71ac8fa6cf4375 kdesignerplugin-5.60.0.tar.xz"