aboutsummaryrefslogtreecommitdiffstats
path: root/community/kea/use-runstatedir-for-pid-file-location.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-08 14:20:56 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-12-08 14:20:37 +0100
commitcbb00b218333fce09e28a8e5eb8730c3945aeb71 (patch)
tree96f5e3fc6e8bb633cad3e856d3ef7f14e9cf9b0f /community/kea/use-runstatedir-for-pid-file-location.patch
parent89442b46ccb0f877da416a75e0f073547b0278f4 (diff)
downloadaports-cbb00b218333fce09e28a8e5eb8730c3945aeb71.tar.bz2
aports-cbb00b218333fce09e28a8e5eb8730c3945aeb71.tar.xz
community/kea: move from testing
Diffstat (limited to 'community/kea/use-runstatedir-for-pid-file-location.patch')
-rw-r--r--community/kea/use-runstatedir-for-pid-file-location.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/kea/use-runstatedir-for-pid-file-location.patch b/community/kea/use-runstatedir-for-pid-file-location.patch
new file mode 100644
index 0000000000..146026b5e0
--- /dev/null
+++ b/community/kea/use-runstatedir-for-pid-file-location.patch
@@ -0,0 +1,34 @@
+From: =?utf-8?b?T25kxZllaiBTdXLDvQ==?= <ondrej@sury.org>
+Date: Tue, 19 Feb 2019 12:55:42 +0000
+Subject: Use runstatedir for pid file location
+
+We have to modify the autohelled Makefile.in instead of Makefile.am because Kea
+requires old automake-1.15.
+
+Patch-Source: https://sources.debian.org/src/isc-kea/1.5.0-2/debian/patches/0004-Use-runstatedir-for-pid-file-location.patch/
+
+--- a/src/lib/process/Makefile.in
++++ b/src/lib/process/Makefile.in
+@@ -487,10 +487,8 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = . testutils tests
+-# DATA_DIR is the directory where to put PID files.
+-dhcp_data_dir = @runstatedir@/@PACKAGE@
+ AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib \
+- -DDATA_DIR="\"$(dhcp_data_dir)\"" $(BOOST_INCLUDES)
++ -DKEA_PIDFILE_DIR="\"$(runstatedir)/$(PACKAGE_NAME)\"" $(BOOST_INCLUDES)
+ AM_CXXFLAGS = $(KEA_CXXFLAGS)
+
+ # Ensure that the message file is included in the distribution
+--- a/src/lib/process/daemon.cc
++++ b/src/lib/process/daemon.cc
+@@ -37,7 +37,7 @@
+
+ Daemon::Daemon()
+ : signal_set_(), signal_handler_(), config_file_(""),
+- pid_file_dir_(DATA_DIR), pid_file_(), am_file_author_(false) {
++ pid_file_dir_(KEA_PIDFILE_DIR), pid_file_(), am_file_author_(false) {
+
+ // The pid_file_dir can be overridden via environment variable
+ // This is primarily intended to simplify testing