aboutsummaryrefslogtreecommitdiffstats
path: root/community/keybinder3/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 20:55:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 21:23:44 -0300
commit3ab00c249f4bb0aeab489bc84afb931cca89216c (patch)
tree8bc500cdec5f1abfb81e7283875bdf83181ad3b2 /community/keybinder3/APKBUILD
parentf022104b2104fd121152184948a220851be7a9a6 (diff)
downloadaports-3ab00c249f4bb0aeab489bc84afb931cca89216c.tar.bz2
aports-3ab00c249f4bb0aeab489bc84afb931cca89216c.tar.xz
community/keybinder3: drop python2
Diffstat (limited to 'community/keybinder3/APKBUILD')
-rw-r--r--community/keybinder3/APKBUILD29
1 files changed, 9 insertions, 20 deletions
diff --git a/community/keybinder3/APKBUILD b/community/keybinder3/APKBUILD
index 65a7982e0f..fe806261c0 100644
--- a/community/keybinder3/APKBUILD
+++ b/community/keybinder3/APKBUILD
@@ -3,44 +3,33 @@
pkgname=keybinder3
_pkgname=keybinder-3.0
pkgver=0.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="Library for registering global key bindings, for gtk-based applications. GTK3 version"
url="https://github.com/engla/keybinder"
arch="all"
-license="GPL-2.0"
-makedepends="gtk+3.0-dev python2-dev py-gobject
-gobject-introspection-dev automake autoconf libtool gnome-common
-gtk-doc"
+license="MIT"
+makedepends="gtk+3.0-dev gobject-introspection-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/engla/keybinder/archive/$_pkgname-v${pkgver}.tar.gz"
-builddir="$srcdir/keybinder-${_pkgname}-v$pkgver"
-
-prepare() {
- default_prepare
- cd "$builddir"
- ./autogen.sh
-}
+source="https://github.com/kupferlauncher/keybinder/releases/download/keybinder-3.0-v$pkgver/keybinder-3.0-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ --build=$CBUILD \
+ --host=$CHOST \
--prefix=/usr \
--enable-shared \
--disable-static \
- --enable-gtk-doc
+ --disable-gtk-doc
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="97311959c10d6d4ebf7e36076b255d7ae969835d43c3fc01c90edf045b59c8f67845b526d84a447b4053962f6830535d748e96432bbcc6e3cc7fa3d2f1493304 keybinder-3.0-v0.3.2.tar.gz"
+sha512sums="14171875e03ade88165f28c7267b66cf9efe34259d7a3072a786ba49dacf8f8d6d84753b1aeedec5dfb0a24028be86bceeebee2f6b1bf5ef2eb79ee45f909b11 keybinder-3.0-0.3.2.tar.gz"