aboutsummaryrefslogtreecommitdiffstats
path: root/community/keybinder3
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-12 15:05:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-14 15:30:16 +0000
commit54aa747039cdb934a2619898a95ebfe698d7c3bc (patch)
tree9d8eb8cb62ea41921a74c79ff899aa4a7310010a /community/keybinder3
parent72886796f9356de8e169c2158a213d980ea06ef0 (diff)
downloadaports-54aa747039cdb934a2619898a95ebfe698d7c3bc.tar.bz2
aports-54aa747039cdb934a2619898a95ebfe698d7c3bc.tar.xz
community/keybinder3: new aport
Diffstat (limited to 'community/keybinder3')
-rw-r--r--community/keybinder3/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/keybinder3/APKBUILD b/community/keybinder3/APKBUILD
new file mode 100644
index 0000000000..cae4a92b5e
--- /dev/null
+++ b/community/keybinder3/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=keybinder3
+_pkgname=keybinder-3.0
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Library for registering global key bindings, for gtk-based applications. GTK3 version"
+url="https://github.com/engla/keybinder"
+arch="all"
+license="GPL2"
+makedepends="gtk+3.0-dev python2-dev py-gobject
+gobject-introspection-dev automake autoconf libtool gnome-common
+gtk-doc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/engla/keybinder/archive/$_pkgname-v${pkgver}.tar.gz"
+builddir="$srcdir/keybinder-${_pkgname}-v$pkgver"
+
+build() {
+ cd "$builddir"
+ ./autogen.sh
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-gtk-doc
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="c2f534d7977b337b333313ac9b8bd6c9 keybinder-3.0-v0.3.1.tar.gz"
+sha256sums="0ebd17f026ce4ff6f0fb4248a95c2962d76b60b8cbccf07de28b07d7c5e42204 keybinder-3.0-v0.3.1.tar.gz"
+sha512sums="dd398ae25db295c68365e9f70e463ab69b5e8594753bfab24b16a0bac5d16e18b85065418b19c7bce8d8d39ede8af7ced8414b5a04f20998790d536c333760ce keybinder-3.0-v0.3.1.tar.gz"