aboutsummaryrefslogtreecommitdiffstats
path: root/community/khotkeys
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-11 16:41:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 16:41:58 -0300
commit52b510ad39c0bee4ca0924d9146225cb74b624ec (patch)
tree4399b457dc1efa9e27d0e595410faca17040e9b7 /community/khotkeys
parent83056c8edefcc811f798dda49546d4c3711b922b (diff)
downloadaports-52b510ad39c0bee4ca0924d9146225cb74b624ec.tar.bz2
aports-52b510ad39c0bee4ca0924d9146225cb74b624ec.tar.xz
community/khotkeys: move from testing
Diffstat (limited to 'community/khotkeys')
-rw-r--r--community/khotkeys/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/khotkeys/APKBUILD b/community/khotkeys/APKBUILD
new file mode 100644
index 0000000000..22f20aee28
--- /dev/null
+++ b/community/khotkeys/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=khotkeys
+pkgver=5.16.5
+pkgrel=0
+arch="all !ppc64le !s390x" # Limited by plasma-workspace-dev
+url="https://www.kde.org/workspaces/plasmadesktop/"
+pkgdesc="Key Accelerator Application"
+license="GPL-2.0-only AND LGPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev kglobalaccel-dev ki18n-dev kio-dev kxmlgui-dev kdelibs4support-dev kdbusaddons-dev kcmutils-dev plasma-framework-dev plasma-workspace-dev kdoctools-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="f389396c058dc261a16f6a73f88babc24dc1d7226e35d798c77629bd3e15f1dc9bc2923f2eedb601df6517b168c251c8c6341f364ee14facf4d267e9e5358f34 khotkeys-5.16.5.tar.xz"