aboutsummaryrefslogtreecommitdiffstats
path: root/community/kiconthemes
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/kiconthemes
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/kiconthemes')
-rw-r--r--community/kiconthemes/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/kiconthemes/APKBUILD b/community/kiconthemes/APKBUILD
new file mode 100644
index 0000000000..8c2391a287
--- /dev/null
+++ b/community/kiconthemes/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kiconthemes
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Support for icon themes"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only"
+depends_dev="qt5-qtsvg-dev karchive-dev ki18n-dev kcoreaddons-dev kconfigwidgets-dev kwidgetsaddons-dev kitemviews-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+options="!check" # 1 Test fail
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="446b424ef97d74d76d8e3741fc4571212f8ca2026b231a8693737db8c6efbd161cadceae9d40ae224dc66149474bdb983ca50f05e9d337808b38f9ceb7d2f61d kiconthemes-5.60.0.tar.xz"