aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmousetool
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-25 12:06:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-25 12:40:03 +0100
commit04842fcba8d027d4a37848b23700a1f383117a74 (patch)
tree6e01fda8eed77ef0c6232a6337b1a9afdf34041a /community/kmousetool
parentab120e1e95cec8bd38a04fc2710a365dde63af6b (diff)
downloadaports-04842fcba8d027d4a37848b23700a1f383117a74.tar.bz2
aports-04842fcba8d027d4a37848b23700a1f383117a74.tar.xz
community/kmousetool: move from testing
Diffstat (limited to 'community/kmousetool')
-rw-r--r--community/kmousetool/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/kmousetool/APKBUILD b/community/kmousetool/APKBUILD
new file mode 100644
index 0000000000..bbc2107f1c
--- /dev/null
+++ b/community/kmousetool/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kmousetool
+pkgver=19.12.0
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/utilities/org.kde.kmousetool"
+pkgdesc="A program that clicks the mouse for you"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev knotifications-dev kxmlgui-dev phonon-dev libxt-dev libxtst-dev"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmousetool-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="40b93453104394764ad6ed86a0db6e3fee627c4d5d398ee34ee79a94b51c576dfa69a46fcdbf572da7715e4f5210c77c63a57491ad5dfd2a7052f8c5fdbe1c7f kmousetool-19.12.0.tar.xz"