aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot-resolver
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-29 00:49:14 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-29 00:59:44 +0100
commit0bd3bb295f4cd915f1be0a81174c0fe7a930bafb (patch)
treeb5507c16614e78341538ba0fc0e0bf34c2351fda /community/knot-resolver
parentf6c9f2cabd95bbfa68af74377875cdf719d35d93 (diff)
downloadaports-0bd3bb295f4cd915f1be0a81174c0fe7a930bafb.tar.bz2
aports-0bd3bb295f4cd915f1be0a81174c0fe7a930bafb.tar.xz
community/knot-resolver: fix segfault in stats module
Diffstat (limited to 'community/knot-resolver')
-rw-r--r--community/knot-resolver/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/community/knot-resolver/APKBUILD b/community/knot-resolver/APKBUILD
index c3e18c45d6..f108aae10b 100644
--- a/community/knot-resolver/APKBUILD
+++ b/community/knot-resolver/APKBUILD
@@ -42,6 +42,10 @@ builddir="$srcdir/$pkgname-$pkgver"
# - CVE-2018-1110
build() {
+ # strict-aliasing breaks stats module - variable "sa" in stats.c:495 is 0x0.
+ # (https://gitlab.labs.nic.cz/knot/knot-resolver/blob/v4.2.2/modules/stats/stats.c#L495)
+ export CFLAGS="$CFLAGS -fno-strict-aliasing"
+
meson build \
--prefix=/usr \
--buildtype=release \