aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot-resolver
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-02 14:41:13 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-02 20:00:52 +0000
commit1385c3c1257e855c9229403e656a2784d5b760ef (patch)
treea18611bc0ef658c4df7aca213135b2a5de448453 /community/knot-resolver
parentfabcb1e01382b67a1ed3527c8eafa061f5136bd5 (diff)
downloadaports-1385c3c1257e855c9229403e656a2784d5b760ef.tar.bz2
aports-1385c3c1257e855c9229403e656a2784d5b760ef.tar.xz
community/knot-resolver: add lmdb-dev
LMDB version in contrib/lmdb is 0.9.21, while the system lmdb is at 0.9.23 with some notable fixes. This change also avoids the need to duplicate main/lmdb/cacheflush.patch to resolve the build on mips*.
Diffstat (limited to 'community/knot-resolver')
-rw-r--r--community/knot-resolver/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/knot-resolver/APKBUILD b/community/knot-resolver/APKBUILD
index b64edfbdf0..05e7f4b847 100644
--- a/community/knot-resolver/APKBUILD
+++ b/community/knot-resolver/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: tcely <knot-resolver+aports@tcely.33mail.com>
pkgname=knot-resolver
pkgver=3.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Minimalistic caching DNS resolver implementation"
url="https://www.knot-resolver.cz/"
# luajit is not available for disabled arches
@@ -14,7 +14,7 @@ depends="lua5.1-sec lua5.1-socket"
depends_dnstap=""
depends_dnstap_dev="fstrm-dev protobuf-c-dev"
depends_http="$pkgname lua5.1-http"
-depends_dev="knot-dev>=2.8.0 libedit-dev libuv-dev luajit-dev $depends_dnstap_dev"
+depends_dev="knot-dev>=2.8.0 libedit-dev libuv-dev lmdb-dev luajit-dev $depends_dnstap_dev"
makedepends="$depends_dev bash dnssec-root vim"
checkdepends="cmocka-dev"
install="$pkgname.pre-install"
@@ -33,6 +33,13 @@ source="https://secure.nic.cz/files/$pkgname/$pkgname-$pkgver.tar.xz
_flags="PREFIX=/usr
ETCDIR=/etc/$pkgname"
+prepare() {
+ default_prepare
+
+ # Make sure embedded LMDB library is not used.
+ rm -rf contrib/lmdb
+}
+
build() {
make $_flags
}