aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot-resolver
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-08 10:00:26 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-08 10:16:01 +0100
commit1dc36494df07d0ba73534d3211cdeaf1f70d8cf9 (patch)
tree15dc8916f0921fe8b0fc56e7084078e47d5ecc5c /community/knot-resolver
parentce7d1af13a73d2830e0495a78da963ffe3b141ce (diff)
downloadaports-1dc36494df07d0ba73534d3211cdeaf1f70d8cf9.tar.bz2
aports-1dc36494df07d0ba73534d3211cdeaf1f70d8cf9.tar.xz
community/knot-resolver: rename initd var config to cfgfile
To be consistent with other init scriptsà This change is backward compatible.
Diffstat (limited to 'community/knot-resolver')
-rw-r--r--community/knot-resolver/APKBUILD10
-rw-r--r--community/knot-resolver/knot-resolver.confd2
-rw-r--r--community/knot-resolver/knot-resolver.initd6
3 files changed, 7 insertions, 11 deletions
diff --git a/community/knot-resolver/APKBUILD b/community/knot-resolver/APKBUILD
index 32e35137a8..a45a40a149 100644
--- a/community/knot-resolver/APKBUILD
+++ b/community/knot-resolver/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=knot-resolver
pkgver=4.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Minimalistic caching DNS resolver implementation"
url="https://www.knot-resolver.cz/"
arch="all !s390x" # limited by luajit
@@ -99,11 +99,7 @@ gpgfingerprints="
B600 6460 B60A 80E7 8206 2449 E747 DF1F 9575 A3AA
"
-sha256sums="03b68dff16429aed7a5b0cea7189276c8056e8ecd567b678c2595d48d9a51458 knot-resolver-4.2.2.tar.xz
-1907cad39d355c03f84997272271933476d335b0e84c4f71490c98b7a2631f20 knot-resolver.logrotate
-357a277602d998bebabb806178c96dd71dc14a73945000480788a9b5cef10a57 knot-resolver.confd
-2c3978a7366a04aba7bac0308d778af4c93ca9497fe10bb96658050a3080cf62 knot-resolver.initd"
sha512sums="53a7cb9419f090609c3ca31f606d40c6b023a1356de79899bc867b0511cc23474ac66af0dbd78cca0a48759ddf95cab6762bb17b24b4d1a376ad8cfdd4042fda knot-resolver-4.2.2.tar.xz
688aeacb0c1f21c7e532533b402e67068897217713fb668636df7533000b493981ddfa0497f8dba7da7c804ee4ab8d587a4f52155b4e2bf1f4025d2588d314bb knot-resolver.logrotate
-0bfab48f3a182eb396c039c932698f9a4bb7d11f5ecd87336fe803cf6e0ef2923c2e516dc6a5cec19595945d24b3b24795d0119fb8560c42b0d268b2c3be6c20 knot-resolver.confd
-902e7773c404ab4862453233e16ec8ccc415759d73aea795062e945034d28537b13397b14dec3b6ef8ec3ea58604e77258e1381e9b62d93ddb9ec3e3e0031244 knot-resolver.initd"
+9a4af28918d85fb973739cc856ac32c07746e4b1b2daee343905d5956bfd6cc45bf5cba87efa56625a9b38aced43aafb793ab37f9a2c06c95a899e47c84ee5a2 knot-resolver.confd
+5891eb694f49ff221233afb0e4d7dcc5879783c3e365732189b623886b3a8351af022d80775bddf25e39f8b930ce9fccaed87384ee793e2746518ec5f3b78324 knot-resolver.initd"
diff --git a/community/knot-resolver/knot-resolver.confd b/community/knot-resolver/knot-resolver.confd
index 0cca4cda70..78d9860346 100644
--- a/community/knot-resolver/knot-resolver.confd
+++ b/community/knot-resolver/knot-resolver.confd
@@ -1,7 +1,7 @@
# Config file for /etc/init.d/knot-resolver
# Config file path.
-#config="/etc/knot-resolver/kresd.conf"
+#cfgfile="/etc/knot-resolver/kresd.conf"
# Cache (working) directory.
#cachedir="/var/cache/knot-resolver"
diff --git a/community/knot-resolver/knot-resolver.initd b/community/knot-resolver/knot-resolver.initd
index 849279f6f3..59b5776442 100644
--- a/community/knot-resolver/knot-resolver.initd
+++ b/community/knot-resolver/knot-resolver.initd
@@ -1,19 +1,19 @@
#!/sbin/openrc-run
-: ${config:="/etc/knot-resolver/kresd.conf"}
+: ${cfgfile:=${config:-"/etc/knot-resolver/kresd.conf"}}
: ${cachedir:="/var/cache/knot-resolver"}
: ${logfile:="/var/log/knot-resolver.log"}
command="/usr/sbin/kresd"
# Note: Do not change forks=1, it's buggy.
-command_args="--config=$config --forks=1 $cachedir"
+command_args="--config=$cfgfile --forks=1 $cachedir"
command_background="yes"
pidfile="/run/$RC_SVCNAME.pid"
start_stop_daemon_args="
--chdir=$cachedir
--stdout=$logfile
--stderr=$logfile"
-required_files="$config"
+required_files="$cfgfile"
depend() {
need net