aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot/APKBUILD
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-07-16 23:15:08 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-26 21:43:34 -0300
commit3810f74b4e9fa86b06304f9ec9b7679d12e2afca (patch)
treefd32cc36b1b070037ae86d09a214dc726389ab83 /community/knot/APKBUILD
parentc76e73c05ebeff14a74ccb315a2fc0d6fc8db016 (diff)
downloadaports-3810f74b4e9fa86b06304f9ec9b7679d12e2afca.tar.bz2
aports-3810f74b4e9fa86b06304f9ec9b7679d12e2afca.tar.xz
community/knot: style changes
Diffstat (limited to 'community/knot/APKBUILD')
-rw-r--r--community/knot/APKBUILD65
1 files changed, 33 insertions, 32 deletions
diff --git a/community/knot/APKBUILD b/community/knot/APKBUILD
index 69abc0409e..78a25fffa4 100644
--- a/community/knot/APKBUILD
+++ b/community/knot/APKBUILD
@@ -3,30 +3,31 @@
# Contributor: Francesco Zanini <francesco@zanini.me>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: tcely <knot+aports@tcely.33mail.com>
-pkgname=knot
-pkgver=2.8.3
+_pkgname="knot"
+pkgname="${_pkgname}"
+pkgver="2.8.3"
pkgrel=0
pkgdesc="An high-performance authoritative-only DNS server"
url="https://www.knot-dns.cz"
arch="all"
license="GPL-3.0-or-later"
depends=""
-depends_dev="$pkgname $pkgname-libs-static $pkgname-utils"
+depends_dev="${pkgname} ${pkgname}-libs-static ${pkgname}-utils"
checkdepends="softhsm"
makedepends="gnutls-dev libedit-dev libcap-ng-dev libidn-dev lmdb-dev
openssl-dev userspace-rcu-dev zlib-dev
m4 bison flex perl sed jansson-dev libtool bsd-compat-headers"
-install="$pkgname.pre-install $pkgname.post-install knot.post-upgrade"
-pkgusers="knot"
-pkggroups="knot"
-subpackages="$pkgname-libs
- $pkgname-libs-static
- $pkgname-utils
- $pkgname-dev
- $pkgname-doc
- $pkgname-openrc
+install="${pkgname}.pre-install ${pkgname}.post-install ${pkgname}.post-upgrade"
+pkgusers="${_pkgname}"
+pkggroups="${_pkgname}"
+subpackages="${pkgname}-libs
+ ${pkgname}-libs-static
+ ${pkgname}-utils
+ ${pkgname}-dev
+ ${pkgname}-doc
+ ${pkgname}-openrc
"
-source="https://secure.nic.cz/files/knot-dns/$pkgname-$pkgver.tar.xz
+source="https://secure.nic.cz/files/${_pkgname}-dns/${_pkgname}-${pkgver}.tar.xz
test_net.patch
knotd.confd
knotd.initd
@@ -35,20 +36,20 @@ source="https://secure.nic.cz/files/knot-dns/$pkgname-$pkgver.tar.xz
prepare() {
default_prepare
- cd "$builddir"
+ cd "${builddir}"
# Make sure embedded LMDB library is not used.
rm -rf src/contrib/lmdb
}
build() {
./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ --build="${CBUILD}" \
+ --host="${CHOST}" \
--prefix=/usr \
--sysconfdir=/etc \
- --libexecdir=/usr/lib/knot \
- --with-rundir=/run/knot \
- --with-storage=/var/lib/knot \
+ --libexecdir="/usr/lib/${_pkgname}" \
+ --with-rundir="/run/${_pkgname}" \
+ --with-storage="/var/lib/${_pkgname}" \
--disable-silent-rules
make
}
@@ -58,34 +59,34 @@ check() {
}
package() {
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir}" install
- rm -rf "$pkgdir"/run
- chown "${pkgusers%% *}:${pkggroups%% *}" "$pkgdir/var/lib/$pkgname"
- chmod 750 "$pkgdir/var/lib/$pkgname"
+ rm -rf "${pkgdir}/run"
+ chown "${pkgusers%% *}:${pkggroups%% *}" "${pkgdir}/var/lib/${_pkgname}"
+ chmod 750 "${pkgdir}/var/lib/${_pkgname}"
- install -Dm 644 "$srcdir"/knotd.confd \
- "$pkgdir"/etc/conf.d/knotd
- install -Dm 755 "$srcdir"/knotd.initd \
- "$pkgdir"/etc/init.d/knotd
+ install -Dm 644 "${srcdir}/knotd.confd" \
+ "${pkgdir}/etc/conf.d/knotd"
+ install -Dm 755 "${srcdir}/knotd.initd" \
+ "${pkgdir}/etc/init.d/knotd"
}
libs() {
pkgdesc="Libraries used by the Knot DNS server and client applications"
- cd "$pkgdir"
- mkdir -p "$subpkgdir"/usr/lib
+ cd "${pkgdir}"
+ mkdir -p "${subpkgdir}/usr/lib"
mv ./usr/lib/libdnssec.so.* \
./usr/lib/libknot.so.* \
./usr/lib/libzscanner.so.* \
- "$subpkgdir"/usr/lib/
+ "${subpkgdir}/usr/lib/"
}
utils() {
pkgdesc="DNS client utilities shipped with the Knot DNS server"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+ mkdir -p "${subpkgdir}/usr"
+ mv "${pkgdir}/usr/bin" "${subpkgdir}/usr/"
}
sha512sums="a5743181807b944c9b6dfce845f009c576125c114fbac7b87592129b724628466740fb77e41cabd8aaf9f046374a9337a1c97ea74b33afae1af6e39e21f8e662 knot-2.8.3.tar.xz