aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-06-06 02:35:36 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 07:55:38 -0300
commit29ae53624f4258092a9c9bea7ad39ba7a425921f (patch)
treed3560c326460a9bf6c346b3fc2c4752ac5c1fab0 /community/knot
parent1ff631da622731be3aaf36b3b030dca576f2227e (diff)
downloadaports-29ae53624f4258092a9c9bea7ad39ba7a425921f.tar.bz2
aports-29ae53624f4258092a9c9bea7ad39ba7a425921f.tar.xz
community/knot: tweak package
Diffstat (limited to 'community/knot')
-rw-r--r--community/knot/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/knot/APKBUILD b/community/knot/APKBUILD
index d2dd7ce405..ff770332b4 100644
--- a/community/knot/APKBUILD
+++ b/community/knot/APKBUILD
@@ -58,9 +58,9 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- rm -Rf "$pkgdir"/run
- chown $pkgusers:$pkggroups "$pkgdir"/var/lib/$pkgname
- chmod 750 "$pkgdir"/var/lib/$pkgname
+ rm -rf "$pkgdir"/run
+ chown "${pkgusers%% *}:${pkggroups%% *}" "$pkgdir/var/lib/$pkgname"
+ chmod 750 "$pkgdir/var/lib/$pkgname"
install -Dm 644 "$srcdir"/knotd.confd \
"$pkgdir"/etc/conf.d/knotd