aboutsummaryrefslogtreecommitdiffstats
path: root/community/kodi
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-03 04:01:10 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-03 12:13:04 +0100
commitdd502921478ee7eeaeace500929d294a09487a28 (patch)
treeecbd7d0105869ddc2c71b6cfbe84ecdc3ea30e1e /community/kodi
parentdd8a947d2130b90fc7fb0b2d15cc2153a8393224 (diff)
downloadaports-dd502921478ee7eeaeace500929d294a09487a28.tar.bz2
aports-dd502921478ee7eeaeace500929d294a09487a28.tar.xz
rebuild against libfmt-6.1.0
The soname didn't change but it still broke.
Diffstat (limited to 'community/kodi')
-rw-r--r--community/kodi/APKBUILD4
-rw-r--r--community/kodi/cassert.patch25
2 files changed, 28 insertions, 1 deletions
diff --git a/community/kodi/APKBUILD b/community/kodi/APKBUILD
index 0661e9fc3b..757c4d7eee 100644
--- a/community/kodi/APKBUILD
+++ b/community/kodi/APKBUILD
@@ -3,7 +3,7 @@
pkgname=kodi
pkgver=18.3
_realname=Leia
-pkgrel=2
+pkgrel=3
_libdvdcss_pkgver="1.4.2-Leia-Beta-5"
_libdvdread_pkgver="6.0.0-Leia-Alpha-3"
_libdvdnav_pkgver="6.0.0-Leia-Alpha-3"
@@ -97,6 +97,7 @@ source="https://github.com/xbmc/xbmc/archive/$pkgver-$_realname.tar.gz
crossguid-$_crossguid_hash.tar.gz::https://mirrors.kodi.tv/build-deps/sources/crossguid-$_crossguid_hash.tar.gz
set-default-stacksize.patch
fix-musl-incompability.patch
+ cassert.patch
kodi.initd
60-kodi.rules
"
@@ -233,5 +234,6 @@ b3419ba0a1a2dd70f1bb6236afdfe1c6e88c9ad4264198b289e3bba9375e077cecf7f89848c7b09d
2682d63609d3dcdfcd8136be632e45df26ad88ce93b9c49745cf728bbd2e6254a7b05c8b059ab581d532372e504206a525a52564b64d076dfdae9c965a09fd16 crossguid-8f399e8bd4.tar.gz
3fd97e9fa22e59b3cd30fdad19474e177a9d062598765fa8ba4955f1da4e10581ff1463dd0794d3ee3cefebf753007a4d445b2bc47a257574d3927c1408b8876 set-default-stacksize.patch
65b78a96bef33cec975b371f1a930d551d7b224955d6075b7edc7e51ec30fec9c77d34f622abbaf827c60df6029206b72c02ee2d2f138d276c1b843336fd14ab fix-musl-incompability.patch
+7348495a805d07730dc569b091f15765ca9d86fa28987a343dfc7fa36cd6ecbb52ac4ea76d7c9fe9eab90ed8552ef6aeae7ffd72edd11f8d780c1de2e9ffe49d cassert.patch
7e2a2289da3098e0007e461ad538dcd6435e908283caf1719788248fe736615890175e11392ca0cd68002872217bbf7b70cf909f228307828aa82467d5502ed4 kodi.initd
465a2079d598bf909a458d8e9d0ddd2b2a41dff83ba736542cffec7811c044295d5af092928f20aaa6cd3bc8b13bb03ede5c7ded1783680f890464e103392787 60-kodi.rules"
diff --git a/community/kodi/cassert.patch b/community/kodi/cassert.patch
new file mode 100644
index 0000000000..5246c5cedc
--- /dev/null
+++ b/community/kodi/cassert.patch
@@ -0,0 +1,25 @@
+diff --git a/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp b/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
+index 222d1fa..0f654ee 100644
+--- a/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
++++ b/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
+@@ -30,6 +30,7 @@
+ #include "utils/log.h"
+ #include "utils/StringUtils.h"
+ #include "utils/URIUtils.h"
++#include <cassert>
+ #include "utils/Variant.h"
+ #include "ServiceBroker.h"
+
+diff --git a/xbmc/windowing/GraphicContext.cpp b/xbmc/windowing/GraphicContext.cpp
+index 1ced496..0ddbe64 100644
+--- a/xbmc/windowing/GraphicContext.cpp
++++ b/xbmc/windowing/GraphicContext.cpp
+@@ -24,6 +24,8 @@
+ #include "guilib/GUIWindowManager.h"
+ #include "guilib/TextureManager.h"
+
++#include <cassert>
++
+ using namespace KODI::MESSAGING;
+
+ CGraphicContext::CGraphicContext(void) = default;