aboutsummaryrefslogtreecommitdiffstats
path: root/community/kolourpaint
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 13:51:59 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:48:38 -0300
commit86739e67abbce4f0360ec34a0b1abb7eb78623db (patch)
treefbf0f515ea0056d9a40dac1a8c24adfb7d32cf5d /community/kolourpaint
parent15a08e31dde3fc03fbbba239e3214b0e454be521 (diff)
downloadaports-86739e67abbce4f0360ec34a0b1abb7eb78623db.tar.bz2
aports-86739e67abbce4f0360ec34a0b1abb7eb78623db.tar.xz
community/kolourpaint: move from testing
Diffstat (limited to 'community/kolourpaint')
-rw-r--r--community/kolourpaint/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/kolourpaint/APKBUILD b/community/kolourpaint/APKBUILD
new file mode 100644
index 0000000000..4e18a6d263
--- /dev/null
+++ b/community/kolourpaint/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kolourpaint
+pkgver=19.08.2
+pkgrel=0
+arch="all"
+url="http://www.kolourpaint.org/"
+pkgdesc="An easy-to-use paint program"
+license="BSD-2-Clauase AND LGPL-2.0-or-later AND GFDL-1.2"
+makedepends="extra-cmake-modules qt5-qtbase-dev kdoctools-dev ki18n-dev kguiaddons-dev kwidgetsaddons-dev kio-dev kxmlgui-dev kiconthemes-dev ktextwidgets-dev kitemmodels-dev kdelibs4support-dev libksane-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/kolourpaint-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="beaf80f8cdc13f23ad19e0832fdb7d95d17fa11a84137e0d2c84c8f5fadd57e4c6cfa03583ebfa52d2c55923dfd9802362f63e04e59829ef205947033b47590f kolourpaint-19.08.2.tar.xz"