aboutsummaryrefslogtreecommitdiffstats
path: root/community/konsole/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-19 02:43:17 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-18 23:59:39 -0300
commit40c1c4fecfee438a92109423634810e089bad6bd (patch)
tree76a35de97135d473f838cd8dd2ccccce11465796 /community/konsole/APKBUILD
parent2667e5bfcd20f08c68c4cb2b9eb5c6a272dd1534 (diff)
downloadaports-40c1c4fecfee438a92109423634810e089bad6bd.tar.bz2
aports-40c1c4fecfee438a92109423634810e089bad6bd.tar.xz
community/konsole: move from testing
Diffstat (limited to 'community/konsole/APKBUILD')
-rw-r--r--community/konsole/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/konsole/APKBUILD b/community/konsole/APKBUILD
new file mode 100644
index 0000000000..827b4a35d0
--- /dev/null
+++ b/community/konsole/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=konsole
+pkgver=19.08.1
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/system/konsole"
+pkgdesc="KDE's terminal emulator"
+license="GPL-2.0-only AND LGPL-2.1-or-later AND Unicode-DFS-2016"
+makedepends="extra-cmake-modules qt5-qtbase-dev kbookmarks-dev kcompletion-dev
+ kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kguiaddons-dev
+ kdbusaddons-dev ki18n-dev kiconthemes-dev kinit-dev kio-dev knewstuff-dev
+ knotifications-dev knotifyconfig-dev kparts-dev kpty-dev kservice-dev
+ ktextwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev
+ kdbusaddons-dev kglobalaccel-dev kdoctools-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/applications/$pkgver/src/konsole-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ # DBusTest requires running DBus
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "DBusTest"
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="e68d51f6307c68f3e0ac2df9f2ab6eedac4984e04154bbc29d67ad6955c6210ebfb659488aac44a797e7e26d4cef0fa0e069e25a1d17a250b73a8cf0aca01696 konsole-19.08.1.tar.xz"