aboutsummaryrefslogtreecommitdiffstats
path: root/community/kparts
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/kparts
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/kparts')
-rw-r--r--community/kparts/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/kparts/APKBUILD b/community/kparts/APKBUILD
new file mode 100644
index 0000000000..3fd627ffbd
--- /dev/null
+++ b/community/kparts/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kparts
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Document centric plugin system"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only AND LGPL-2.1+ AND (LGPL-2.1-only OR LGPL-3.0-only)"
+depends_dev="qt5-qtbase-dev kconfig-dev kcoreaddons-dev ki18n-dev kiconthemes-dev
+ kio-dev kjobwidgets-dev kservice-dev ktextwidgets-dev kwidgetsaddons-dev kxmlgui-dev"
+makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="97e59c7e176d62e7c3b3b06481a82792e7429c99eb23fc5d661fb792521ed925b5a98e70cd7c810c4488aa57b341f340c88f34473c9a418187c5b224ac070f26 kparts-5.60.0.tar.xz"