aboutsummaryrefslogtreecommitdiffstats
path: root/community/kquickcharts
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-14 20:58:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-16 22:31:13 +0100
commitbd5c4358f87e54910c40c9e40a4d3b9dd1c92d0e (patch)
tree5a3d335286ba0fcdc5949abab5d099e0ce66faed /community/kquickcharts
parentf04ee37a250ca0060fcb760b1760365ee9e33044 (diff)
downloadaports-bd5c4358f87e54910c40c9e40a4d3b9dd1c92d0e.tar.bz2
aports-bd5c4358f87e54910c40c9e40a4d3b9dd1c92d0e.tar.xz
community/kquickcharts: move from testing
Diffstat (limited to 'community/kquickcharts')
-rw-r--r--community/kquickcharts/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/kquickcharts/APKBUILD b/community/kquickcharts/APKBUILD
new file mode 100644
index 0000000000..56fcd089a5
--- /dev/null
+++ b/community/kquickcharts/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kquickcharts
+pkgver=5.65.0
+pkgrel=0
+pkgdesc="A QtQuick plugin providing high-performance charts"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kded-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="ec382a920861e666c07f65183ad2548de6d74ad3a55a49a2be889a9f447772aa02845b7e6ea81daac31eb43a23ca6a71157aaf1d4a8c8438f8459b1b85b8f0d3 kded-5.65.0.tar.xz"