aboutsummaryrefslogtreecommitdiffstats
path: root/community/kscreenlocker
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/kscreenlocker
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
downloadaports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.bz2
aports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.xz
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/kscreenlocker')
-rw-r--r--community/kscreenlocker/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/kscreenlocker/APKBUILD b/community/kscreenlocker/APKBUILD
index 2b570be7eb..712bfe9bee 100644
--- a/community/kscreenlocker/APKBUILD
+++ b/community/kscreenlocker/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kscreenlocker
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="Library and components for secure lock screen architecture"
arch="all"
@@ -11,14 +11,21 @@ depends="linux-pam elogind"
depends_dev="qt5-qtbase-dev qt5-qtx11extras-dev kcrash-dev kdeclarative-dev kglobalaccel-dev ki18n-dev kidletime-dev kcmutils-dev knotifications-dev solid-dev ktextwidgets-dev kwindowsystem-dev kxmlgui-dev xcb-util-keysyms-dev kwayland-dev linux-pam-dev libseccomp-dev elogind-dev"
makedepends="$depends_dev extra-cmake-modules"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz
+source="https://download.kde.org/stable/plasma/$pkgver/kscreenlocker-$pkgver.tar.xz
kde.pam
kde-np.pam"
subpackages="$pkgname-dev $pkgname-lang"
options="!check" # Requires running loginctl
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -26,16 +33,18 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
install -D -m644 "$srcdir"/kde.pam "$pkgdir"/etc/pam.d/kde
install -m644 "$srcdir"/kde-np.pam "$pkgdir"/etc/pam.d/kde-np
}
-sha512sums="ce7cef6ca4bcd94f716b70df26691dc70b7709421d56827ef2e355a3350af71779168cf17c0437e53ef0fc930f20590a7e7ffa5f11ea01d3a4f2f25e1fa00549 kscreenlocker-5.16.5.tar.xz
+sha512sums="c66247aad2523a0b86bd0a1952b122b6dba279038f0c6b1931cbdc6d9d9f2463e89f8f2114e5ec8f5c4835b9130fec7f5ff2fa7d046708c84d88ee66a231696e kscreenlocker-5.17.0.tar.xz
56e87d02d75c4a8cc4ed183faed416fb4972e7f223b8759959c0f5da32e11e657907a1df279d62a44a6a174f5aca8b2ac66a5f3325c5deb92011bcf71eed74c3 kde.pam
565265485dd7466b77966d75a56766216b8bcc187c95a997e531e9481cf50ddbe576071eb0e334421202bcab19aa6de6b93e042447ca4797a24bf97e1d053ffd kde-np.pam"