aboutsummaryrefslogtreecommitdiffstats
path: root/community/ksshaskpass
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:28:26 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:33 -0300
commit276167c5ab28835e9621f038cb1c87cb1aed1ad6 (patch)
tree57c22b283c6348b55768d23946b5aec656ea55be /community/ksshaskpass
parent16cfac4a855726daba93f11311fe50caf585ec86 (diff)
downloadaports-276167c5ab28835e9621f038cb1c87cb1aed1ad6.tar.bz2
aports-276167c5ab28835e9621f038cb1c87cb1aed1ad6.tar.xz
community/ksshaskpass: move from testing
Diffstat (limited to 'community/ksshaskpass')
-rw-r--r--community/ksshaskpass/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/ksshaskpass/APKBUILD b/community/ksshaskpass/APKBUILD
new file mode 100644
index 0000000000..7610b27ab3
--- /dev/null
+++ b/community/ksshaskpass/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=ksshaskpass
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="ssh-add helper that uses kwallet and kpassworddialog"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev ki18n-dev kwallet-dev kwidgetsaddons-dev kdoctools-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="b2ca1245ca55fce2fdd722b5b318bf137efffb9d6ee8ece30706cc369b51e1943f738cd95be29a01fd74e184175f4ce0d6fefdc58a2a621d80358dbfe293cfb9 ksshaskpass-5.16.5.tar.xz"