aboutsummaryrefslogtreecommitdiffstats
path: root/community/ksysguard
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:29:04 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:33 -0300
commit179ffd1a267fc5f3bd47461de870394619124026 (patch)
tree87b8d81519a666361b9a6cce82a16c5b81391ccc /community/ksysguard
parent276167c5ab28835e9621f038cb1c87cb1aed1ad6 (diff)
downloadaports-179ffd1a267fc5f3bd47461de870394619124026.tar.bz2
aports-179ffd1a267fc5f3bd47461de870394619124026.tar.xz
community/ksysguard: move from testing
Diffstat (limited to 'community/ksysguard')
-rw-r--r--community/ksysguard/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/ksysguard/APKBUILD b/community/ksysguard/APKBUILD
new file mode 100644
index 0000000000..ad9ce637c2
--- /dev/null
+++ b/community/ksysguard/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=ksysguard
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Track and control the processes running in your system"
+arch="all !ppc64le !s390x" # Limited by libksysguard -> qt5-qtwebengine
+url="https://userbase.kde.org/KSysGuard"
+license="GPL-2.0-only"
+makedepends="extra-cmake-modules kconfig-dev kcoreaddons-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev kinit-dev kitemviews-dev kio-dev knewstuff-dev knotifications-dev kwindowsystem-dev libksysguard-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="579175da2cc4d9255b36890b716e1f060106a24c609d4cd92accc38aa2c47bf9723e1a19dfa80678619db811b59b40c853655bf678c187d802e137978c3a970b ksysguard-5.16.5.tar.xz"