aboutsummaryrefslogtreecommitdiffstats
path: root/community/libabw
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-19 02:36:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-19 02:41:15 -0300
commitc49c350abc6db75bba18746f6eaf73bb029f21d8 (patch)
tree0d3342c2a00888fceb0b9b4f3e5f595adf224ea0 /community/libabw
parentd9c55aed533d7afb8c4ecb2eefd4018008184c11 (diff)
downloadaports-c49c350abc6db75bba18746f6eaf73bb029f21d8.tar.bz2
aports-c49c350abc6db75bba18746f6eaf73bb029f21d8.tar.xz
community/libabw: upgrade to 0.1.3
Diffstat (limited to 'community/libabw')
-rw-r--r--community/libabw/APKBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/community/libabw/APKBUILD b/community/libabw/APKBUILD
index 692c7e73ba..200bf232f7 100644
--- a/community/libabw/APKBUILD
+++ b/community/libabw/APKBUILD
@@ -1,22 +1,17 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer:
pkgname=libabw
-pkgver=0.1.2
+pkgver=0.1.3
pkgrel=0
pkgdesc="Import filter and tools for AbiWord documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libabw"
arch="all"
license="MPL-2.0"
-depends_dev="librevenge-dev libxml2-dev zlib-dev boost-dev"
-makedepends="$depends_dev doxygen gperf perl"
+makedepends="doxygen gperf perl librevenge-dev libxml2-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
-
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://dev-www.libreoffice.org/src/libabw/libabw-$pkgver.tar.xz"
build() {
- cd "$builddir"
-
# workaround for boost 1.59
export CPPFLAGS='-DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED'
./configure \
@@ -26,13 +21,11 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- --disable-werror
+ --localstatedir=/var
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -41,4 +34,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="a365c1aa047a97a86eee6bce8463646bdf248a51013139ee288402a832fd545586e072d7c7fc11a56f42e3637de9e922197be20d0587e53c51fd80ced409a6cd libabw-0.1.2.tar.xz"
+sha512sums="0d2646e1bad1e11b3da43714ac5931fc67ffdbc4e7a25a44ef5b6e6a41de1e0ae14596b4a87cceb07bf56dbbe9344622b3d60afcb054ee0ab8577ca8e9b5c289 libabw-0.1.3.tar.xz"