aboutsummaryrefslogtreecommitdiffstats
path: root/community/libdbi-drivers
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-20 10:55:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-20 10:55:33 +0000
commit4ae55f56d7841219a62737942a7329cf7f54484e (patch)
treec5a35ebc7ffbb1f81073d576860760dda0696a57 /community/libdbi-drivers
parente4eea5aca6d215f9d8c0ec90149099beb3d1bf8e (diff)
downloadaports-4ae55f56d7841219a62737942a7329cf7f54484e.tar.bz2
aports-4ae55f56d7841219a62737942a7329cf7f54484e.tar.xz
community/libdbi-drivers: build fix aarch64
Diffstat (limited to 'community/libdbi-drivers')
-rw-r--r--community/libdbi-drivers/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/community/libdbi-drivers/APKBUILD b/community/libdbi-drivers/APKBUILD
index b64ebfaf4e..90678c76ca 100644
--- a/community/libdbi-drivers/APKBUILD
+++ b/community/libdbi-drivers/APKBUILD
@@ -16,19 +16,15 @@ subpackages=""
options="libtool"
source="http://downloads.sourceforge.net/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
-_builddir=${srcdir}/${pkgname}-${pkgver}
+builddir=${srcdir}/${pkgname}-${pkgver}
+
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare || return 1
+ update_config_guess || return 1
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--localstatedir=/usr \
--with-mysql \
@@ -40,7 +36,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
chmod -R o-w "$pkgdir"/usr/lib/libdbi
}